aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-01-02 20:59:45 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-01-03 06:55:40 +0100
commit78a9cfa33e66c5647cea66980d83f49a43e27f60 (patch)
tree7b7316674bd957c58f1699948db033a96525edac
parentdd8292df5f49f05014606dabbfd8934e4827d8d1 (diff)
downloadguix-78a9cfa33e66c5647cea66980d83f49a43e27f60.tar.gz
guix-78a9cfa33e66c5647cea66980d83f49a43e27f60.zip
gnu: perl-search-xapian: Update to 1.2.25.4.
* gnu/packages/search.scm (perl-search-xapian): Update to 1.2.25.4.
-rw-r--r--gnu/packages/search.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/search.scm b/gnu/packages/search.scm
index 0a5fa38b30..8293d562b3 100644
--- a/gnu/packages/search.scm
+++ b/gnu/packages/search.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2015, 2016 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018, 2020, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Adam Massmann <massmannak@gmail.com>
;;;
;;; This file is part of GNU Guix.
@@ -116,15 +116,14 @@ rich set of boolean query operators.")
(define-public perl-search-xapian
(package
(name "perl-search-xapian")
- (version "1.2.25.2")
+ (version "1.2.25.4")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://cpan/authors/id/O/OL/OLLY/"
"Search-Xapian-" version ".tar.gz"))
(sha256
- (base32
- "0hpa8gi38j0ibq8af6dy69lm1bl5jnq76nsa69dbrzbr88l5m594"))))
+ (base32 "1pbl8pbgmbs3i8yik4p63g4pd9bhn0dp3d7l667dkvw0kccl66c7"))))
(build-system perl-build-system)
(native-inputs
`(("perl-devel-leak" ,perl-devel-leak)))
cktrace page on user abort....When the user aborts the installation because a core dump is discovered or the installation command failed, displaying the abort backtrace doesn't make much sense. Hide it when the abort condition is &user-abort-error and skip directly to the dump page. * gnu/installer/steps.scm (&user-abort-error): New variable. (user-abort-error?): New procedure. * gnu/installer/newt/final.scm (run-install-failed-page): Raise a user-abort-error. * gnu/installer/newt/welcome.scm (run-welcome-page): Ditto. * gnu/installer.scm (installer-program): Hide the backtrace page and directly propose to dump the report when the a &user-abort-error is raised. Mathieu Othacehe 2022-11-02installer: Add core dump support....Fixes: <https://issues.guix.gnu.org/58733> * gnu/installer.scm (installer-program): Enable core dump generation. * gnu/installer/dump.scm (%core-dump): New variable. (prepare-dump): Copy the core dump file. * gnu/installer/newt/welcome.scm (run-welcome-page): Propose to report an installation that previously generated a core dump. Mathieu Othacehe