aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-15 19:26:59 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:32 +0200
commit76efb0fbd26033d56bab4dc562a93dc5f15d3a81 (patch)
tree1b1b30365c273c9238d26f9b3b334d93142c6c9c
parent9aa2f5228dc0dcd89bbcb9f7315add7281c18c33 (diff)
downloadguix-76efb0fbd26033d56bab4dc562a93dc5f15d3a81.tar.gz
guix-76efb0fbd26033d56bab4dc562a93dc5f15d3a81.zip
gnu: texlive-mathpazo: Refresh package definition.
* gnu/packages/tex.scm (texlive-mathpazo): Remove SIMPLE-TEXLIVE-PACKAGE call.
-rw-r--r--gnu/packages/tex.scm44
1 files changed, 24 insertions, 20 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 0981fecbe4..8bd58a1188 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11024,28 +11024,32 @@ Symbol font from Adobe's basic set.")
(define-public texlive-mathpazo
(package
- (inherit (simple-texlive-package
- "texlive-mathpazo"
- (list "/doc/latex/mathpazo/"
- "/fonts/afm/public/mathpazo/"
- "/fonts/tfm/public/mathpazo/"
- "/fonts/type1/public/mathpazo/"
- "/fonts/vf/public/mathpazo/")
- (base32
- "02in6hdnbnkz216mpy8g6fk3wmlls8nh5982vmg37vhbj77lk0rh")
- #:trivial? #t))
- (home-page "http://www.ctan.org/pkg/mathpazo")
+ (name "texlive-mathpazo")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/mathpazo/"
+ "fonts/afm/public/mathpazo/"
+ "fonts/tfm/public/mathpazo/"
+ "fonts/type1/public/mathpazo/"
+ "fonts/vf/public/mathpazo/"
+ "source/latex/mathpazo/")
+ (base32
+ "0g10rjgg1kb78lgyxmwjrkgpy24yq3v0m47h6zhbc68rrmmawvwp")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (propagated-inputs (list texlive-fpl texlive-palatino))
+ (home-page "https://ctan.org/pkg/mathpazo")
(synopsis "Fonts to typeset mathematics to match Palatino")
(description "The Pazo Math fonts are a family of PostScript fonts
-suitable for typesetting mathematics in combination with the Palatino
-family of text fonts. The Pazo Math family is made up of five fonts
-provided in Adobe Type 1 format. These contain glyphs that are
-usually not available in Palatino and for which Computer Modern looks
-odd when combined with Palatino. These glyphs include the uppercase
-Greek alphabet in upright and slanted shapes, the lowercase Greek
-alphabet in slanted shape, several mathematical glyphs and the
-uppercase letters commonly used to represent various number sets.
-LaTeX macro support is provided in package @code{psnfss}.")
+suitable for typesetting mathematics in combination with the Palatino family
+of text fonts. The Pazo Math family is made up of five fonts provided in
+Adobe Type 1 format. These contain glyphs that are usually not available in
+Palatino and for which Computer Modern looks odd when combined with Palatino.
+These glyphs include the uppercase Greek alphabet in upright and slanted
+shapes, the lowercase Greek alphabet in slanted shape, several mathematical
+glyphs and the uppercase letters commonly used to represent various number
+sets. LaTeX macro support is provided in package @code{psnfss}.")
(license license:gpl3+)))
(define-public texlive-fp