aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-05-07 18:24:17 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:39 +0000
commit7347fb453afd6083fee2130f85ed53b590f31ecb (patch)
tree9914d8d82e76c981d0cae91c59ced140ca9ab158
parent699bc5db6b683783e6c07f0051269c345c46ef2d (diff)
downloadguix-7347fb453afd6083fee2130f85ed53b590f31ecb.tar.gz
guix-7347fb453afd6083fee2130f85ed53b590f31ecb.zip
gnu: python-argon2-cffi: Update to 21.1.0.
* gnu/packages/python-crypto.scm (python-argon2-cffi): Update to 21.1.0. [source]: Simplify snippet. [arguments]: Do not quote list; respect TESTS? in 'check phase. [propagated-inputs]: Add python-typing-extensions; remove python-six. Change-Id: Ifeee408dbcb43ff435cc1e9563df07f89df3ffb2
-rw-r--r--gnu/packages/python-crypto.scm29
1 files changed, 16 insertions, 13 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 5624224357..3203f4dd6c 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -1592,36 +1592,39 @@ I/O-free core, and integration modules for different event loops.")
(define-public python-argon2-cffi
(package
(name "python-argon2-cffi")
- (version "20.1.0")
+ (version "21.1.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "argon2-cffi" version))
(sha256
(base32
- "0zgr4mnnm0p4i99023safb0qb8cgvl202nly1rvylk2b7qnrn0nq"))
+ "0w5q5cdwmzpjgw3bl9f6b9a5xai87qvx3jryra9gd8fi0c8vc47p"))
(modules '((guix build utils)))
- (snippet '(begin (delete-file-recursively "extras") #t))))
+ (snippet '(delete-file-recursively "extras"))))
+ ;; TODO: with pyproject-build-system the install phase fails.
(build-system python-build-system)
(arguments
- '(#:phases
- (modify-phases %standard-phases
+ (list
+ #:phases
+ '(modify-phases %standard-phases
(replace 'build
(lambda _
(setenv "ARGON2_CFFI_USE_SYSTEM" "1")
(invoke "python" "setup.py" "build")))
(replace 'check
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (add-installed-pythonpath inputs outputs)
- (invoke "pytest")
- (invoke "python" "-m" "argon2" "--help")
- ;; see tox.ini
- (invoke "python" "-m" "argon2" "-n" "1" "-t" "1" "-m" "8" "-p" "1"))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest")
+ (invoke "python" "-m" "argon2" "--help")
+ ;; see tox.ini
+ (invoke "python" "-m" "argon2" "-n" "1" "-t" "1" "-m" "8" "-p" "1")))))))
(propagated-inputs
- (list python-cffi python-six))
+ (list python-cffi python-typing-extensions))
(inputs (list argon2))
(native-inputs
- (list python-hypothesis python-pytest))
+ (list python-hypothesis
+ python-pytest))
(home-page "https://argon2-cffi.readthedocs.io/")
(synopsis "Secure Password Hashes for Python")
(description