aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-11-20 13:59:44 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-11-20 14:00:14 +0100
commit72ef08da9d4cd811d59be95bebc0ea8492427587 (patch)
tree657e5d5a9824be9bf44b4860adb0ed5b75bf2ac0
parent603bee5f3b670b06d6594e63066dc0c6d836c921 (diff)
downloadguix-72ef08da9d4cd811d59be95bebc0ea8492427587.tar.gz
guix-72ef08da9d4cd811d59be95bebc0ea8492427587.zip
gnu: python-uvicorn: Update to 0.32.0.
* gnu/packages/python-web.scm (python-uvicorn): Update to 0.32.0. [arguments]: Enable more tests; add phase 'patch-pyproject. Change-Id: I7b1efb0a8319d02a8ea83a03299b1c2fa3adf0aa
-rw-r--r--gnu/packages/python-web.scm22
1 files changed, 12 insertions, 10 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 8bc998669c..c030deeb12 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -6515,7 +6515,7 @@ and fairly speedy.")
(define-public python-uvicorn
(package
(name "python-uvicorn")
- (version "0.23.2")
+ (version "0.32.0")
(source
(origin
;; PyPI tarball has no tests.
@@ -6525,17 +6525,19 @@ and fairly speedy.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1qa4cwifss9cnasfr0ffn76rvh7wcfjkl6nw99yz43rjmdpj3h7p"))))
+ (base32 "0csl5drf58yhih6kyl5imkkb1hsv24c99fjkzhr3pmzas0jahf1d"))))
(build-system pyproject-build-system)
(arguments
- (list #:test-flags
- #~(list "-o" "asyncio_mode=auto"
- "-k"
- (string-join
- ;; These error or fail due to networking.
- '("not test_keepalive"
- "not test_bind_unix_socket_works_with_reload_or_workers")
- " and "))))
+ (list
+ #:test-flags
+ '(list "-o" "asyncio_mode=auto")
+ #:phases
+ '(modify-phases %standard-phases
+ (add-after 'unpack 'patch-pyproject
+ (lambda _
+ ;; Hatchling doesn't like this.
+ (substitute* "pyproject.toml"
+ ((".*Programming Language :: Python :: 3.13.*") "")))))))
(native-inputs
(list python-a2wsgi
python-hatchling