aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 16:46:15 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:42:20 +0200
commit72d9dcaca20687476775fa103ebaacab963a55bd (patch)
treeee550ccf21d893c1eacbb04b1606d9b4562a2c8d
parent5ee3da33ce46b84ef1cfca0dabd6a98fa284e61c (diff)
downloadguix-72d9dcaca20687476775fa103ebaacab963a55bd.tar.gz
guix-72d9dcaca20687476775fa103ebaacab963a55bd.zip
gnu: Add texlive-scratchx.
* gnu/packages/tex.scm (texlive-scratchx): New variable.
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f25fe97770..13fed981d1 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5992,6 +5992,25 @@ effortless pretty-printing of SuperCollider source code in documents typeset
with LaTeX and friends.")
(license license:lppl1.3+)))
+(define-public texlive-scratchx
+ (package
+ (name "texlive-scratchx")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/scratchx/" "tex/latex/scratchx/")
+ (base32
+ "1vy8599n8hxrvjc063p1dis0y7y221rlcwxxxryvibhz2kk7zwc2")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/scratchx")
+ (synopsis "Include Scratch programs in LaTeX documents")
+ (description
+ "This package can be used to include every kind of Scratch program in
+LaTeX documents. This may be particularly useful for Math Teachers and IT
+specialists.")
+ (license license:lppl1.3c)))
+
(define-public texlive-bibtex8
(package
(name "texlive-bibtex8")