aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-11-10 14:37:58 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-11-28 11:05:06 +0200
commit72937ab60b7da0c2873f347d9ac7d05491839c91 (patch)
treeb8641a6da3b899a360254ac2056e8b1c39a53c01
parentbf353caf7cd453f47ffad8a211f8cae1b1c8e6ff (diff)
downloadguix-72937ab60b7da0c2873f347d9ac7d05491839c91.tar.gz
guix-72937ab60b7da0c2873f347d9ac7d05491839c91.zip
gnu: rust-async-executor-1: Update to 1.13.1.
* gnu/packages/crates-io.scm (rust-async-executor-1): Update to 1.13.1. [cargo-inputs]: Replace rust-fastrand-1 with 2, rust-futures-lite-1 with 2. Remove rust-async-lock-2. [cargo-development-inputs]: Add rust-async-lock-3, rust-fastrand-2, rust-futures-lite-2. Replace rust-async-channel-1 with 2, rust-async-io-1 with 2, rust-criterion-0.4 with 0.5. Remove rust-num-cpus-1. Change-Id: Iab73ab86fef687dad1a80b7ffa1d9ff9bff6d88e
-rw-r--r--gnu/packages/crates-io.scm21
1 files changed, 11 insertions, 10 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 2cdc4c23f5..76778bd95d 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -5073,29 +5073,30 @@ AsyncSeek if the inner type does.")
(define-public rust-async-executor-1
(package
(name "rust-async-executor")
- (version "1.5.1")
+ (version "1.13.1")
(source
(origin
(method url-fetch)
(uri (crate-uri "async-executor" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "1yrs723d4djhia5mimc85blrvly0kl8bj260b5vz0r4559gxr8vg"))))
+ (base32 "1v6w1dbvsmw6cs4dk4lxj5dvrikc6xi479wikwaab2qy3h09mjih"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs
- (("rust-async-lock" ,rust-async-lock-2)
- ("rust-async-task" ,rust-async-task-4)
+ (("rust-async-task" ,rust-async-task-4)
("rust-concurrent-queue" ,rust-concurrent-queue-2)
- ("rust-fastrand" ,rust-fastrand-1)
- ("rust-futures-lite" ,rust-futures-lite-1)
+ ("rust-fastrand" ,rust-fastrand-2)
+ ("rust-futures-lite" ,rust-futures-lite-2)
("rust-slab" ,rust-slab-0.4))
#:cargo-development-inputs
- (("rust-async-channel" ,rust-async-channel-1)
- ("rust-async-io" ,rust-async-io-1)
- ("rust-criterion" ,rust-criterion-0.4)
+ (("rust-async-channel" ,rust-async-channel-2)
+ ("rust-async-io" ,rust-async-io-2)
+ ("rust-async-lock" ,rust-async-lock-3)
+ ("rust-criterion" ,rust-criterion-0.5)
("rust-easy-parallel" ,rust-easy-parallel-3)
- ("rust-num-cpus" ,rust-num-cpus-1)
+ ("rust-fastrand" ,rust-fastrand-2)
+ ("rust-futures-lite" ,rust-futures-lite-2)
("rust-once-cell" ,rust-once-cell-1))))
(home-page "https://github.com/stjepang/async-executor")
(synopsis "Async executor")