aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2025-03-03 17:31:42 -0500
committerJohn Kehayias <john.kehayias@protonmail.com>2025-03-03 17:35:14 -0500
commit72923a75af53a819f2be9dc4ae3c096aa3147d3f (patch)
tree740b70f53b6da978e1dc8cde2d9894e5e22c4f54
parenta7e6fb6bc3b2a5e12599a9200eab619d8309b0a7 (diff)
downloadguix-72923a75af53a819f2be9dc4ae3c096aa3147d3f.tar.gz
guix-72923a75af53a819f2be9dc4ae3c096aa3147d3f.zip
gnu: godot: Update to 4.4.
* gnu/packages/game-development.scm (godot): Update to 4.4. [source]: Update snippet to preserve jolt_physics and manifold. [arguments]<#:phases>: Update scons-use-env phase to match upstream changes. Change-Id: I7b4bd9557aeb24f2256ded3883ca7676b4a62a32
-rw-r--r--gnu/packages/game-development.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 52c9a38f9f..a026e114c4 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -2379,7 +2379,7 @@ scripted in a Python-like language.")
(define-public godot
(package
(name "godot")
- (version "4.3")
+ (version "4.4")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2388,7 +2388,7 @@ scripted in a Python-like language.")
(file-name (git-file-name name version))
(sha256
(base32
- "1hqjlhjhxyp1kll7s68b34kisvba1d5dsr804flc0bw4f47l2sdz"))
+ "1la1sk6v3scpgvv7gpqxbmh6vybz5v67jbl19ks07i50g8bpiswx"))
(modules '((guix build utils)
(ice-9 ftw)
(srfi srfi-1)))
@@ -2421,9 +2421,11 @@ scripted in a Python-like language.")
;; which is no longer in the glslang output
;; after the most recent update.
"glslang"
+ "jolt_physics"
"jpeg-compressor"
"libktx"
"libsimplewebm"
+ "manifold"
"meshoptimizer"
"minimp3"
"miniupnpc"
@@ -2489,9 +2491,9 @@ scripted in a Python-like language.")
;; Scons does not use the environment variables by default,
;; but this substitution makes it do so.
(substitute* "SConstruct"
- (("env = Environment\\(tools=custom_tools\\)")
+ (("env = Environment\\(tools=\\[\\]\\)")
(string-append
- "env = Environment(tools=custom_tools)\n"
+ "env = Environment(tools=[])\n"
"env = Environment(ENV=os.environ)")))))
(add-after 'scons-use-env 'fix-dlopen-paths
(lambda* (#:key inputs #:allow-other-keys)