aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 10:52:00 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 11:17:30 +0200
commit72794f220334dc6ff2524f6c5926101f43655714 (patch)
tree80b38721e2908cbb31394dcb1c81d7010c9367da
parentf2179ba604a4d3b87de8ed9f35dbcdc937a84b9e (diff)
downloadguix-72794f220334dc6ff2524f6c5926101f43655714.tar.gz
guix-72794f220334dc6ff2524f6c5926101f43655714.zip
gnu: Add texlive-gobble.
* gnu/packages/tex.scm (texlive-gobble): New variable.
-rw-r--r--gnu/packages/tex.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f76e96c82a..5145dac52a 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2781,6 +2781,36 @@ invented by Gottlob Frege in 1879 for his books @emph{Begriffsschrift} and
books are supported.")
(license license:gpl3)))
+(define-public texlive-gobble
+ (package
+ (name "texlive-gobble")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/generic/gobble/"
+ "source/generic/gobble/"
+ "tex/generic/gobble/")
+ (base32
+ "02g40fx99xn80af6bqv7zn16l8dnqihqd42vn5hbphfx85b3p49q")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (native-inputs (list texlive-ydoc))
+ (home-page "https://ctan.org/pkg/gobble")
+ (synopsis "More gobble macros for PlainTeX and LaTeX")
+ (description
+ "The LaTeX package @code{gobble} includes several gobble macros not
+included in the LaTeX kernel. These macros remove a number of arguments after
+them, a feature regulary used inside other macros. This includes gobble
+macros for optional arguments.
+
+The LaTeX package @code{gobble-user} provides these macros at the user level,
+i.e. using names without @samp{@@@@} so that these can be used without
+@code{\\makeatletter} and @code{\\makeatother}. The same macros are provided
+inside @file{.tex} files for use with plain-TeX or other TeX formats.
+However, the gobble macros for optional macros require @code{\\@@@@ifnextchar}
+to be defined.")
+ (license license:lppl1.3+)))
+
(define-public texlive-tex
(package
(name "texlive-tex")