aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-12 21:50:33 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:56 +0200
commit71ca1465dc12dbb8f885ea9a5228b4a34ffdf7d1 (patch)
tree6256b1e16595caf093efe8ca91e9fe12b4fbf59a
parent75677daa8341946b906a2712188c2d349f6174aa (diff)
downloadguix-71ca1465dc12dbb8f885ea9a5228b4a34ffdf7d1.tar.gz
guix-71ca1465dc12dbb8f885ea9a5228b4a34ffdf7d1.zip
gnu: Add texlive-adigraph.
* gnu/packages/tex.scm (texlive-adigraph): New variable.
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 153e89161f..b9477b7ff7 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -15955,6 +15955,25 @@ ligatures (ff, fi, ffi, fl, ffl) in legacy TrueType fonts (those
lacking a liga table) accessed via @code{fontspec}.")
(license license:public-domain)))
+(define-public texlive-adigraph
+ (package
+ (name "texlive-adigraph")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/adigraph/" "tex/latex/adigraph/")
+ (base32
+ "0qzljcd1g0a9mwj0nrqc2xbka9si27a5d9hg3y7kk73n50zsxv5x")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/adigraph")
+ (synopsis "Augmenting directed graphs")
+ (description
+ "This LaTeX package provides the means to easily draw augmenting oriented
+graphs, as well as cuts on them, to demonstrate steps of algorithms for
+solving max-flow min-cut problems.")
+ (license license:expat)))
+
(define-public texlive-adjustbox
(package
(name "texlive-adjustbox")