aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRodion Goritskov <rodion.goritskov@gmail.com>2024-07-03 23:30:22 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-11 12:38:54 +0100
commit71161e697ededc0b17da2b5323713cfedc9fd5a7 (patch)
treeea1af3bc44878dddbeedc4596d63dd142e281039
parent1ff5daf53b134fef0d3c35944f7106d0aa7db0c7 (diff)
downloadguix-71161e697ededc0b17da2b5323713cfedc9fd5a7.tar.gz
guix-71161e697ededc0b17da2b5323713cfedc9fd5a7.zip
gnu: Add go-github-com-fxamacker-cbor-v2.
* gnu/packages/golang-xyz.scm (go-github-com-fxamacker-cbor-v2): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: I19e13404586613fd4629c35f50264120df264c6b
-rw-r--r--gnu/packages/golang-xyz.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index f7e40550ff..eeefefb3f8 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1912,6 +1912,36 @@ quoting, commenting, and escaping.")
(home-page "https://github.com/flynn-archive/go-shlex")
(license license:asl2.0))))
+(define-public go-github-com-fxamacker-cbor-v2
+ (package
+ (name "go-github-com-fxamacker-cbor-v2")
+ (version "2.7.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/fxamacker/cbor")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "039lk7n5155gy2sh55i1darcvxhv9fim2xmnvmx0xi9ihnrnczln"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/fxamacker/cbor/v2"))
+ (propagated-inputs
+ (list go-github-com-x448-float16))
+ (home-page "https://github.com/fxamacker/cbor")
+ (synopsis "CBOR Codec in Golang")
+ (description
+ "This package implements functionality for encoding and decoding
+@acronym{Concise Binary Object
+Representation,CBOR} (@url{https://www.rfc-editor.org/rfc/rfc8949.html,RFC
+8949}) and CBOR Sequences, with CBOR tags, Golang struct tags (@code{toarray},
+@code{keyasint}, @code{omitempty}), @code{float64/32/16}, and
+@code{big.Intp}.")
+ (license license:expat)))
+
(define-public go-github-com-gabriel-vasile-mimetype
(package
(name "go-github-com-gabriel-vasile-mimetype")