aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-23 13:32:24 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:23:31 +0000
commit70dbb0720a51eb0584e88a90fe3b1e2868b3e4ce (patch)
treeab04a7d4a6202ad6fac765a87c745a3b1b2dc9e4
parentde3a139b3c74952e527933400600db251cffbe03 (diff)
downloadguix-70dbb0720a51eb0584e88a90fe3b1e2868b3e4ce.tar.gz
guix-70dbb0720a51eb0584e88a90fe3b1e2868b3e4ce.zip
gnu: python-tornado-6: Update to 6.4.2.
* gnu/packages/python-web.scm (python-tornado-6): Update to 6.4.2. [native-inputs]: Add python-pytest, python-setuptools, and python-wheel. Change-Id: I4338745b18eec94f0f492b80b1d5b99f69a37085
-rw-r--r--gnu/packages/python-web.scm23
1 files changed, 11 insertions, 12 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 85ece68fb2..bd39b9e691 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2749,25 +2749,24 @@ connection to each user.")
(define-public python-tornado-6
(package
(name "python-tornado")
- (version "6.2")
+ (version "6.4.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "tornado" version))
(sha256
- (base32
- "04rwzjfqa31ajz8vvkfcsp1539m8n960msnppxkcckp8plch8qwv"))))
- (build-system python-build-system)
+ (base32 "02v2mlvr58xg0l0gh08nswl53z73wkf23sziggypk63ffjsdbflj"))))
+ (build-system pyproject-build-system)
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (setenv "ASYNC_TEST_TIMEOUT" "25") ; Like in tox.ini.
- (invoke "python" "-m" "tornado.test.runtests")))))))
+ (list
+ #:test-flags
+ ;; AttributeError: 'TestIOStreamWebMixin' object has no attribute 'io_loop'
+ #~(list "--ignore=tornado/test/iostream_test.py")))
(native-inputs
- (list python-certifi))
+ (list python-certifi
+ python-pytest
+ python-setuptools
+ python-wheel))
(home-page "https://www.tornadoweb.org/")
(synopsis "Python web framework and asynchronous networking library")
(description