aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-13 10:25:52 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:17:43 +0200
commit6ff4e948868f84bd438f620beb9cc1d98d882d03 (patch)
tree026028b9dfae5b9e1d709117adc36f3e7459775a
parenta01d92a1e51d5ce56342de0d2ba896c955f456ab (diff)
downloadguix-6ff4e948868f84bd438f620beb9cc1d98d882d03.tar.gz
guix-6ff4e948868f84bd438f620beb9cc1d98d882d03.zip
gnu: Add texlive-scratch3.
* gnu/packages/tex.scm (texlive-scratch3): New variable.
-rw-r--r--gnu/packages/tex.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index edeb535d12..fb16270cfe 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3855,6 +3855,24 @@ From now on, Scratch is now version 3 with a new design. Use the
@code{scratch3} package to draw blocks with the new design.")
(license license:lppl1.3c)))
+(define-public texlive-scratch3
+ (package
+ (name "texlive-scratch3")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/scratch3/" "tex/latex/scratch3/")
+ (base32
+ "0g8s0p7j058z7hdm4p7kgh7nsyk4wn22lp3j25d5b4hr0xyxmhby")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/scratch3")
+ (synopsis "Draw programs like Scratch")
+ (description
+ "This package permits to draw program charts in the style of the
+@url{https://scratch.mit.edu, Scratch} project.")
+ (license license:lppl1.3c)))
+
(define-public texlive-amiri
(package
(name "texlive-amiri")