aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:02:01 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:06:28 +0200
commit6f846eda45191f1536435c0fb23e3790f5e88ba7 (patch)
treee8b8c48c51c97110157230796432183a3d4cc2bc
parent8f8a0d333d4006ee25d08ae845ad7619f3520130 (diff)
downloadguix-6f846eda45191f1536435c0fb23e3790f5e88ba7.tar.gz
guix-6f846eda45191f1536435c0fb23e3790f5e88ba7.zip
gnu: Add texlive-styledcmd.
* gnu/packages/tex.scm (texlive-styledcmd): New variable.
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 0ca6004ecd..1cbc2d97ab 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -96637,6 +96637,27 @@ a new handout. As a secondary feature, the package defines a basic visual
style for handouts. This style can be easily changed.")
(license license:lppl1.3+)))
+(define-public texlive-styledcmd
+ (package
+ (name "texlive-styledcmd")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/styledcmd/"
+ "source/latex/styledcmd/"
+ "tex/latex/styledcmd/")
+ (base32
+ "0828ay5kyd0z77mh1y590m3ln52awi0rcdmdp5djlx1198xlvfj5")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/styledcmd")
+ (synopsis "Handling multiple versions of user-defined macros")
+ (description
+ "This package allows creating and maintaining different versions of the same
+command, in order to choose the best option for every document. This includes
+expandable and protected commands.")
+ (license license:gpl3+)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar