aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2023-04-20 16:42:09 +0200
committerLudovic Courtès <ludo@gnu.org>2023-04-20 16:42:09 +0200
commit6d32421f6e3546380bf0a5fdc378a6988b6cd952 (patch)
treeb98a0b38e40214c022d863a82e5b554b922f3f88
parentc7d6fe2792969b1a6585dc41307f920b68b5b955 (diff)
downloadguix-6d32421f6e3546380bf0a5fdc378a6988b6cd952.tar.gz
guix-6d32421f6e3546380bf0a5fdc378a6988b6cd952.zip
gnu: python-unittest2: Adjust patch for Python 3.10 compatibility.
* gnu/packages/patches/python-unittest2-python3-compat.patch: Add hunk for Python 3.10 compatibility.
-rw-r--r--gnu/packages/patches/python-unittest2-python3-compat.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/patches/python-unittest2-python3-compat.patch b/gnu/packages/patches/python-unittest2-python3-compat.patch
index fe0afe559a..68fbccacd0 100644
--- a/gnu/packages/patches/python-unittest2-python3-compat.patch
+++ b/gnu/packages/patches/python-unittest2-python3-compat.patch
@@ -32,3 +32,15 @@ index 683f662..347eea5 100644
def test_loadTestsFromNames__relative_malformed_name(self):
loader = unittest.TestLoader()
+diff --git a/unittest2/compatibility.py b/unittest2/compatibility.py
+index 9e5f1a5..2d20c19 100644
+--- a/unittest2/compatibility.py
++++ b/unittest2/compatibility.py
+@@ -140,6 +140,6 @@ except ImportError:
+ ### ChainMap (helper for configparser and string.Template)
+ ########################################################################
+
+-class ChainMap(collections.MutableMapping):
++class ChainMap(collections.abc.MutableMapping):
+ ''' A ChainMap groups multiple dicts (or other mappings) together
+ to create a single, updateable view.