aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-12-11 18:49:55 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2020-12-11 19:17:01 +0100
commit6ca66f641485cc5a06ba7d34b9c36b738ea1d654 (patch)
treefaffefa52ff3e90f7a90f1739284c3cdf31d5d4a
parent2ae3033449a6ee803fc3ead77c5f26967e9dc34c (diff)
downloadguix-6ca66f641485cc5a06ba7d34b9c36b738ea1d654.tar.gz
guix-6ca66f641485cc5a06ba7d34b9c36b738ea1d654.zip
gnu: ecl-lparallel: Disable never ending tests.
* gnu/packages/lisp-xyz.scm (ecl-lparallel)[arguments]: Disable tests.
-rw-r--r--gnu/packages/lisp-xyz.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 7ec625c8bf..f77e949fea 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -2764,7 +2764,11 @@ Lisp, featuring:
(sbcl-package->cl-source-package sbcl-lparallel))
(define-public ecl-lparallel
- (sbcl-package->ecl-package sbcl-lparallel))
+ (package
+ (inherit (sbcl-package->ecl-package sbcl-lparallel))
+ (arguments
+ ;; TODO: Find why the tests get stuck forever; disable them for now.
+ `(#:tests? #f))))
(define-public sbcl-cl-markup
(let ((commit "e0eb7debf4bdff98d1f49d0f811321a6a637b390"))