aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntero Mejr <antero@mailbox.org>2023-06-04 17:42:16 +0000
committerDanny Milosavljevic <dannym@friendly-machines.com>2024-12-22 13:13:27 +0100
commit6ca5c2e50e2b3161245123cc87103e94e9af9e63 (patch)
tree1435e3c0097b8f6005695c8c3870ce0d3fb859d8
parentbb7c2643d864ad54047cb53ad8db52f31568f0b2 (diff)
downloadguix-6ca5c2e50e2b3161245123cc87103e94e9af9e63.tar.gz
guix-6ca5c2e50e2b3161245123cc87103e94e9af9e63.zip
gnu: Add perl-file-libmagic.
* gnu/packages/perl.scm (perl-file-libmagic): New variable. Signed-off-by: Danny Milosavljevic <dannym@friendly-machines.com>
-rw-r--r--gnu/packages/perl.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 5df42a4f57..f6a6352a72 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -72,6 +72,7 @@
#:use-module (gnu packages bash)
#:use-module (gnu packages compression)
#:use-module (gnu packages databases)
+ #:use-module (gnu packages file)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages gcc)
@@ -5248,6 +5249,30 @@ that arise trying to find them consistently across a wide variety of
platforms.")
(license (package-license perl))))
+(define-public perl-file-libmagic
+ (package
+ (name "perl-file-libmagic")
+ (version "1.23")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/D/DR/DROLSKY/File-LibMagic-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1vk775386z4pz4y8m916rhlczs5rw12s36s3vx67mn5jgkfb3rjj"))))
+ (build-system perl-build-system)
+ (arguments
+ (list #:tests? #f)) ;1/33 fails, "gzip file is application/pdf ..."
+ (native-inputs (list perl-config-autoconf perl-test-fatal))
+ (inputs (list file))
+ (home-page "https://metacpan.org/release/File-LibMagic")
+ (synopsis "Determine MIME types of data or files using libmagic")
+ (description
+ "The @code{File::LibMagic} module is a simple perl interface to libmagic
+from the file package.")
+ (license (package-license perl))))
+
(define-public perl-file-path
(package
(name "perl-file-path")