aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 15:07:09 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 15:45:51 +0200
commit6aad0085becd2c051f1fa4cd982bc05dd6ca1e34 (patch)
treea8025bb078e9535755ab1434be149479b1ec3331
parent97f316d3dee6f20bad94cffa48b9f846497cd9de (diff)
downloadguix-6aad0085becd2c051f1fa4cd982bc05dd6ca1e34.tar.gz
guix-6aad0085becd2c051f1fa4cd982bc05dd6ca1e34.zip
gnu: Add texlive-chess.
* gnu/packages/tex.scm (texlive-chess): New variable.
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index bc18a06b97..f2a9298e0c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4193,6 +4193,29 @@ formatting chemistry documents according to the conventions of a number of
leading journals. It also provides some handy chemistry-related macros.")
(license license:lppl1.3+)))
+(define-public texlive-chess
+ (package
+ (name "texlive-chess")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/fonts/chess/"
+ "fonts/source/public/chess/"
+ "fonts/tfm/public/chess/" "tex/latex/chess/")
+ (base32
+ "079naqw9bd5da3c2bsa0322kdjrfpwa35inrfznzgrfdk1w0irs7")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (native-inputs (list texlive-metafont))
+ (home-page "https://ctan.org/pkg/chess")
+ (synopsis "Fonts for typesetting chess boards")
+ (description
+ "This is the original, and somewhat dated, TeX chess font package.
+Potential users should consider @code{skak} (for alternative fonts, and
+notation support), @code{texmate} (for alternative notation support), or
+@code{chessfss} (for flexible font choices).")
+ (license license:public-domain)))
+
(define-public texlive-chhaya
(package
(name "texlive-chhaya")