aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-01-23 13:30:59 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-01-23 13:42:55 +0100
commit6a82745746d8bfb910dae7d2c17b13ba0e5dc8bc (patch)
treee6c36efae0f9e78a1312999afa145500fb5ba306
parent1bdc4eeb46f97a313aaa1d480528a86458980807 (diff)
downloadguix-6a82745746d8bfb910dae7d2c17b13ba0e5dc8bc.tar.gz
guix-6a82745746d8bfb910dae7d2c17b13ba0e5dc8bc.zip
gnu: Add python-magic-impute.
* gnu/packages/bioinformatics.scm (python-magic-impute): New variable. Change-Id: Iba5240e9920a1045078c736553cb1d56069963b5
-rw-r--r--gnu/packages/bioinformatics.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 40a264fd61..b403fdbdf5 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2149,6 +2149,45 @@ matplotlib Axes objects, making them easy to style and incorporate into
multi-panel figures.")
(license license:expat)))
+(define-public python-magic-impute
+ (package
+ (name "python-magic-impute")
+ (version "1.2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/KrishnaswamyLab/MAGIC")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1yjs16vg87lcg9g16bnblg1v9sk73j6dm229lkcz0bfjlzxjhv8w"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:tests? #false ;there are none
+ #:phases
+ '(modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _ (chdir "python"))))))
+ (propagated-inputs
+ (list python-future
+ python-graphtools
+ python-matplotlib
+ python-numpy
+ python-pandas
+ python-scikit-learn
+ python-scipy
+ python-tasklogger))
+ (home-page "https://github.com/KrishnaswamyLab/MAGIC")
+ (synopsis "Markov affinity-based graph imputation of cells")
+ (description "MAGIC is an interactive tool to impute missing values in
+single-cell sequencing data and to restore the structure of the data. It also
+provides data pre-processing functionality such as dimensionality reduction
+and gene expression visualization.")
+ (license license:gpl2+)))
+
(define-public python-parabam
(package
(name "python-parabam")