aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-15 21:40:22 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:38 +0200
commit69647e82150ddcf994efb2d954b0fb6187ca52a3 (patch)
tree6c9de6a3a5fb8193cbc36d909c8b5bc11df0dd84
parent6e535c932de0f5999cc28be1350c9e86b3954b86 (diff)
downloadguix-69647e82150ddcf994efb2d954b0fb6187ca52a3.tar.gz
guix-69647e82150ddcf994efb2d954b0fb6187ca52a3.zip
gnu: texlive-xunicode: Refresh package definition.
* gnu/packages/tex.scm (texlive-xunicode): Remove SIMPLE-TEXLIVE-PACKAGE call. [propagated-inputs]: Add TEXLIVE-GRAPHICS.
-rw-r--r--gnu/packages/tex.scm30
1 files changed, 17 insertions, 13 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 1e85a11b1c..6ac44af79a 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -10112,21 +10112,25 @@ such as footnotes and section titles.")
(define-public texlive-xunicode
(package
- (inherit
- (simple-texlive-package "texlive-xunicode"
- (list "doc/xelatex/xunicode/"
- "tex/xelatex/xunicode/")
- (base32
- "1d96i8kd2lhbykc3rxy2jjvws404f2vy1cvdcp5bdr6l9m72q1fa")
- #:trivial? #t))
- (propagated-inputs (list texlive-tipa))
- (home-page "https://ctan.org/macros/xetex/latex/xunicode")
+ (name "texlive-xunicode")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/xelatex/xunicode/"
+ "tex/xelatex/xunicode/")
+ (base32
+ "1d96i8kd2lhbykc3rxy2jjvws404f2vy1cvdcp5bdr6l9m72q1fa")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (propagated-inputs
+ (list texlive-graphics texlive-tipa))
+ (home-page "https://ctan.org/pkg/xunicode")
(synopsis "Generate Unicode characters from accented glyphs")
(description
- "The package supports XeTeX's (and other putative future similar engines')
-need for Unicode characters, in a similar way to what the fontenc does for
-8-bit (and the like) fonts: convert accent-glyph sequence to a single Unicode
-character for output. The package also covers glyphs specified by
+ "The package supports XeTeX's (and other putative future similar
+engines') need for Unicode characters, in a similar way to what the fontenc
+does for 8-bit (and the like) fonts: convert accent-glyph sequence to a single
+Unicode character for output. The package also covers glyphs specified by
packages (such as @code{tipa}) which define many commands for single text
glyphs.")
(license license:lppl1.3+)))