aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-13 10:46:28 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:04 +0200
commit677f5556c140161b956c2cd7de129abb2dd1426e (patch)
treed72867e7b8d411b78d4ceec729def93a89ce62c9
parentb53b09a9763c5999575d6c07ac0b03a1fe0d63f4 (diff)
downloadguix-677f5556c140161b956c2cd7de129abb2dd1426e.tar.gz
guix-677f5556c140161b956c2cd7de129abb2dd1426e.zip
gnu: Add texlive-tikzpfeile.
* gnu/packages/tex.scm (texlive-tikzpfeile): New variable.
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 35562189cc..ee21592061 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5157,6 +5157,29 @@ jester, judge, maninblack, mexican, nun, nurse, physician, pilot, police,
priest, sailor, santa, surgeon.")
(license license:lppl1.3+)))
+(define-public texlive-tikzpfeile
+ (package
+ (name "texlive-tikzpfeile")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/tikzpfeile/"
+ "source/latex/tikzpfeile/"
+ "tex/latex/tikzpfeile/")
+ (base32
+ "0h6kkrm462hk2hvbdqqjai3gxsslibghxbjyq3ih0vps7fakglc6")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/tikzpfeile")
+ (synopsis "Draw arrows using PGF/TikZ")
+ (description
+ "In a document with a lot of diagrams created with PGF/TikZ, there is
+a possibility of the reader being distracted by different sorts of arrowheads
+in the diagrams and in the text (as, e.g., in @code{\\rightarrow}). The
+package defines macros to create all arrows using PGF/TikZ, so as to avoid the
+problem.")
+ (license license:lppl)))
+
(define-public texlive-amiri
(package
(name "texlive-amiri")