aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 09:31:35 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 09:48:36 +0200
commit676e73a6fce244f09d5eb8833b4342bfae14f239 (patch)
tree21cdd22eb04ff64eeb0e1fd089b9be87c45fa5d1
parent0a8e86831b57c10fb553ca7854c715e72368bf33 (diff)
downloadguix-676e73a6fce244f09d5eb8833b4342bfae14f239.tar.gz
guix-676e73a6fce244f09d5eb8833b4342bfae14f239.zip
gnu: Add texlive-gregoriotex.
* gnu/packages/tex.scm (texlive-gregoriotex): New variable.
-rw-r--r--gnu/packages/tex.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 070cb03525..11e79a4723 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6675,6 +6675,32 @@ The package also provides an interface to control various settings including
algorithm parameters.")
(license license:expat)))
+(define-public texlive-gregoriotex
+ (package
+ (name "texlive-gregoriotex")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/luatex/gregoriotex/"
+ "fonts/source/gregoriotex/"
+ "fonts/truetype/public/gregoriotex/"
+ "scripts/gregoriotex/"
+ "source/luatex/gregoriotex/"
+ "tex/lualatex/gregoriotex/"
+ "tex/luatex/gregoriotex/")
+ (base32
+ "0lnpq6rfdb6dg543cmbsm817ziim6arxnzxzbn0wn8i8aw681idr")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/gregoriotex")
+ (synopsis "Engraving gregorian chant scores")
+ (description
+ "Gregorio is a software application for engraving gregorian chant scores
+on a computer. Gregorio's main job is to convert a gabc file (simple text
+representation of a score) into a GregorioTeX file, which makes TeX able to
+create a PDF of your score.")
+ (license license:gpl3)))
+
(define-public texlive-grundgesetze
(package
(name "texlive-grundgesetze")