aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Tournier <zimon.toutoune@gmail.com>2024-09-10 03:27:12 +0200
committerLudovic Courtès <ludo@gnu.org>2024-12-16 00:19:56 +0100
commit6606c464908b5f618351230fe27c8ea45620db91 (patch)
tree04b6144db3132b93937c4c20e601c76907c5b3ab
parent9320d860294fb6af3fe085e2b4c15a95f87b2b94 (diff)
downloadguix-6606c464908b5f618351230fe27c8ea45620db91.tar.gz
guix-6606c464908b5f618351230fe27c8ea45620db91.zip
gnu: smithforth: Move system.fs origin from phases to native-inputs.
* gnu/packages/dlang.scm (smithforth)[arguments]<phases>: Move system.fs origin from here... [native-inputs]: ...to here. Change-Id: I82ff81f72dbe2ecf70fbbd44674596e1a62cadcf Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/forth.scm20
1 files changed, 11 insertions, 9 deletions
diff --git a/gnu/packages/forth.scm b/gnu/packages/forth.scm
index 6e8d8cdc4c..c523887871 100644
--- a/gnu/packages/forth.scm
+++ b/gnu/packages/forth.scm
@@ -75,7 +75,15 @@ included.")
(sha256
(base32 "0a39pv7529llsa3f48fmvwvlcp3f9v8qkn5ziw2l6kxf0qvli3lm"))))
(build-system trivial-build-system)
- (native-inputs (list xxd))
+ (native-inputs (list xxd
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://dacvs.neocities.org/SF/system"
+ version "fs.txt"))
+ (sha256
+ (base32
+ "17v1pp64s6n8q8w3kg48nd7zdcx2208y4svr5fpfms5lkyzg7z1m")))))
(arguments
(list
#:modules '((guix build utils))
@@ -84,14 +92,8 @@ included.")
(use-modules (guix build utils)
(ice-9 textual-ports))
(let* ((sforth.dmp #$(package-source this-package))
- (system.fs #$(origin
- (method url-fetch)
- (uri (string-append
- "https://dacvs.neocities.org/SF/system"
- version "fs.txt"))
- (sha256
- (base32
- "17v1pp64s6n8q8w3kg48nd7zdcx2208y4svr5fpfms5lkyzg7z1m"))))
+ (system.fs #$(this-package-native-input
+ (string-append "system" version "fs.txt")))
(xxd (string-append (assoc-ref %build-inputs "xxd")
"/bin/xxd"))
(bin (string-append (assoc-ref %outputs "out") "/bin")))