aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2024-06-18 19:09:44 +0800
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:45:11 +0200
commit6515a705ae23a4d810da085e3fee2d1f1f97f73b (patch)
tree77c6d628f50c579646e54475e29bce31e25884dc
parent47e761b929db9ecdfbb209a5280803606f9da19f (diff)
downloadguix-6515a705ae23a4d810da085e3fee2d1f1f97f73b.tar.gz
guix-6515a705ae23a4d810da085e3fee2d1f1f97f73b.zip
gnu: agda: Fix build.
* gnu/packages/agda.scm (agda)[arguments]: Don't refer to nonexistent 'compile' phase. Change-Id: Ibc9aa38a31c22c9be3a3997882e62129a47938a3
-rw-r--r--gnu/packages/agda.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/agda.scm b/gnu/packages/agda.scm
index c2ebf09e4a..4afe583b2e 100644
--- a/gnu/packages/agda.scm
+++ b/gnu/packages/agda.scm
@@ -102,7 +102,7 @@
(add-after 'unpack 'set-ld-library-path
(lambda _
(setenv "LD_LIBRARY_PATH" (string-append (getcwd) "/dist/build"))))
- (add-after 'compile 'agda-compile
+ (add-after 'build 'agda-compile
(lambda* (#:key outputs #:allow-other-keys)
(let ((agda-compiler (string-append #$output "/bin/agda")))
(for-each (cut invoke agda-compiler <>)