aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2023-06-27 12:08:57 +0100
committerChristopher Baines <mail@cbaines.net>2023-07-10 08:25:58 +0100
commit64d72579d901a7f53e07ca66f2c7e246186b08d8 (patch)
treec4710947a6ed140a3b2f6d9656b335da5b069c78
parent058294caed6faeab78bfeac80e6fba67c42038e1 (diff)
downloadguix-64d72579d901a7f53e07ca66f2c7e246186b08d8.tar.gz
guix-64d72579d901a7f53e07ca66f2c7e246186b08d8.zip
gnu: ruby-listen: Update to 3.8.0.
* gnu/packages/ruby.scm (ruby-listen): Update to 3.8.0. [arguments]: Update style.
-rw-r--r--gnu/packages/ruby.scm34
1 files changed, 17 insertions, 17 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 1ae8341f6b..379c137b6c 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7742,7 +7742,7 @@ a native C extension.")
(define-public ruby-listen
(package
(name "ruby-listen")
- (version "3.2.0")
+ (version "3.8.0")
(source
(origin
;; The gem does not include a Rakefile, so fetch from the Git
@@ -7754,24 +7754,24 @@ a native C extension.")
(file-name (git-file-name name version))
(sha256
(base32
- "1hkp1g6hk5clsmbd001gkc12ma6s459x820piajyasv61m87if24"))))
+ "1skkglml094dw1xr4742in1rwwa84ld0mz4nkw6qa8pwhx48x2n5"))))
(build-system ruby-build-system)
(arguments
- `(#:test-target "spec"
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-files-in-gemspec
- (lambda _
- (substitute* "listen.gemspec"
- (("`git ls-files -z`") "`find . -type f -printf '%P\\\\0' |sort -z`"))
- #t))
- (add-before 'check 'remove-unnecessary-dependencies'
- (lambda _
- (substitute* "Rakefile"
- ;; Rubocop is for code linting, and is unnecessary for running
- ;; the tests.
- ((".*rubocop.*") ""))
- #t)))))
+ (list
+ #:test-target "spec"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-files-in-gemspec
+ (lambda _
+ (substitute* "listen.gemspec"
+ (("`git ls-files -z`")
+ "`find . -type f -printf '%P\\\\0' |sort -z`"))))
+ (add-before 'check 'remove-unnecessary-dependencies'
+ (lambda _
+ (substitute* "Rakefile"
+ ;; Rubocop is for code linting, and is unnecessary for running
+ ;; the tests.
+ ((".*rubocop.*") "")))))))
(native-inputs
(list bundler ruby-rspec))
(inputs