aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-21 21:49:24 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-30 15:10:46 +0000
commit63508a6548ab4f5b6209b90ce8507ad2d597ab41 (patch)
tree1023ddfd660306c3091c85779d23ea2a54e777cf
parent4181877dcdf377ca93a7ee116120044df5cbc014 (diff)
downloadguix-63508a6548ab4f5b6209b90ce8507ad2d597ab41.tar.gz
guix-63508a6548ab4f5b6209b90ce8507ad2d597ab41.zip
gnu: python-gatspy: Adjust inputs.
* gnu/packages/astronomy.scm (python-gatspy) [native-inputs]: Remove python-nose. Change-Id: Ifbbaedf62817339743ac2313626cd058134479d9
-rw-r--r--gnu/packages/astronomy.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 547e216043..f400877ffe 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2158,12 +2158,14 @@ CFITSIO library. Among other things, it can
;; Tests need this
(add-before 'check 'set-HOME
(lambda _ (setenv "HOME" "/tmp"))))))
+ (native-inputs
+ (list python-pytest
+ python-setuptools-scm))
(propagated-inputs
(list python-astroml
python-numpy
python-scipy
python-supersmoother))
- (native-inputs (list python-pytest python-nose python-setuptools-scm))
(home-page "https://github.com/astroml/gatspy")
(synopsis "General tools for astronomical time series in Python")
(description