aboutsummaryrefslogtreecommitdiff
path: root/nix
/gnu/packages/bioconductor.scm?id=63033b159a748935c55df4f12deea4c496544bb8'>gnu/packages/bioconductor.scm
@@ -6367,14 +6367,14 @@ sequential way to mimic the manual gating strategy.")
(define-public r-cytoml
(package
(name "r-cytoml")
- (version "2.0.5")
+ (version "2.2.1")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "CytoML" version))
(sha256
(base32
- "174brv027mm90lydfg6hnhazwh8jy4vf6ial4hpsfalwa5jrz55n"))))
+ "1d8x49aqc95x1vx456hya5r7mal80pj9l6wmr5x5pb5r8qyzz6yq"))))
(properties `((upstream-name . "CytoML")))
(build-system r-build-system)
(inputs
AgeCommit message (Expand)Author
2017-02-07daemon: Define 'NIX_STORE' before invoking 'guix perform-download'....Reported by rohit yadav <rohityadav@utexas.edu> at <https://lists.gnu.org/archive/html/guix-devel/2017-02/msg00191.html>. This fixes a regression whereby 'guix perform-download' would always see NIX_STORE as unset and thus use "/gnu/store", leading it to miscompute the hydra.gnu.org content-addressed URLs when the store file name is not "/gnu/store". * nix/libstore/builtins.cc (builtinDownload): Add 'setenv' call for 'NIX_STORE'. Ludovic Courtès
2017-01-15daemon: Client settings no longer override daemon settings....Fixes <http://bugs.gnu.org/20217>. * nix/libstore/worker-protocol.hh (PROTOCOL_VERSION): Bump to 0x161. * nix/nix-daemon/nix-daemon.cc (performOp): "build-max-jobs", "build-max-silent-time", and "build-cores" are no longer read upfront; instead, read them from the key/value list at the end. * nix/nix-daemon/guix-daemon.cc (main): Explicitly set 'settings.maxBuildJobs'. * guix/store.scm (%protocol-version): Bump to #x161. (set-build-options): #:max-build-jobs, #:max-silent-time, and #:build-cores now default to #f. Adjust handshake to new protocol. * tests/store.scm ("build-cores"): New test. * tests/guix-daemon.sh: Add test for default "build-cores" value. Ludovic Courtès
2017-01-11daemon: Allow check builds of 'builtin:download' derivations....Fixes <http://bugs.gnu.org/25089>. Reported by Leo Famulari <leo@famulari.name>. * nix/libstore/build.cc (DerivationGoal::runChild): In the 'isBuiltin' case, check whether DRV's output is in 'redirectedOutputs', and pass an 'output' argument to the built-in builder. (DerivationGoal::addHashRewrite): Add 'printMsg' call. * nix/libstore/builtins.hh (derivationBuilder): Add 'output' parameter. * nix/libstore/builtins.cc (builtinDownload): Likewise. Add OUTPUT to ARGV. * guix/scripts/perform-download.scm (perform-download): Add 'output' parameter. (guix-perform-download): Adjust 'match' clauses accordingly. * tests/derivations.scm ("'download' built-in builder, check mode"): New test. Ludovic Courtès
2016-12-29daemon: Allow fixed-output derivation builds with TMPDIR set....Fixes <http://bugs.gnu.org/25242>. Reported by Leo Famulari <leo@famulari.name>. The regression was introduced in 94d92c7796a3dd50c27d532315f7d497ac99f08e. * nix/libstore/build.cc (DerivationGoal::startBuilder): Set 'useChroot' as a function 'of isBuiltin(drv)'. (DerivationGoal::runChild): Use 'useChroot' instead of 'useChroot && !isBuiltin(drv)'. Ludovic Courtès
lass='msg-avail'>...* gnu/packages/libidn.scm (libidn2): Update to 2.0.1. [source]: Download from main GNU server. [arguments]: Remove 'create-pkgconfig-file phase. Efraim Flashner 2017-03-30Merge branch 'master' into core-updates...Most conflicts are from 6fd52309b8f52c9bb59fccffac53e029ce94b698. Marius Bakke 2017-03-30gnu: Use HTTPS for almost all gnu.org HOME-PAGEs....All HTTP gnu.org (and supported subdomain) HOME-PAGEs changed to HTTPS. Tobias Geerinckx-Rice 2017-03-14gnu: libidn2: Create 'pkg-config' file....* gnu/packages/libidn.scm (libidn2)[arguments]: Add phase creating libidn2.pc. Marius Bakke 2017-02-06gnu: libidn2: Update to 0.16....* gnu/packages/libidn.scm (libidn2): Update to 0.16. [inputs]: Add libunistring. Leo Famulari 2016-11-06Merge branch 'master' into core-updatesMark H Weaver 2016-11-05gnu: libidn: Distinguish from libidn2....* gnu/packages/libidn.scm (libidn)[description]: Add detail to help distinguish from libidn2. Leo Famulari 2016-11-05gnu: Add libidn2....* gnu/packages/libidn.scm (libidn2): New variable. Leo Famulari 2016-09-02gnu: libidn: Replace with 1.33 [fixes CVE-2015-8948 and CVE-2016-{6261,6263}]....* gnu/packages/libidn.scm (libidn)[replacement]: New field. (libidn-1.33): New variable. Leo Famulari 2016-08-14gnu: libidn: Update to 1.33....* gnu/packages/libidn.scm (libidn): Update to 1.33. Leo Famulari 2016-05-16gnu: libidn: Update license....* gnu/packages/libidn.scm (libidn)[license]: Change the license to gpl2+ gpl3+ lgpl3+ fdl1.3+. Efraim Flashner