aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRodion Goritskov <rodion.goritskov@gmail.com>2025-03-01 18:20:17 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2025-03-05 14:25:06 +0900
commit630201dba8f48dce96b0f0d27a668bbd537cda77 (patch)
tree579af01385511d76dded8818e4652a3a54b1baba
parent97be0a837e7f069b25dc76f86f7d6510601830f2 (diff)
downloadguix-630201dba8f48dce96b0f0d27a668bbd537cda77.tar.gz
guix-630201dba8f48dce96b0f0d27a668bbd537cda77.zip
gnu: xdg-desktop-portal: Fix configuration file search.
* gnu/local.mk: Add patch. * gnu/packages/freedesktop.scm (xdg-desktop-portal): Add patch. * gnu/packages/patches/xdg-desktop-portal-disable-configuration-search-exit.patch: New file Change-Id: Idd637f5613e7d1403fc3a0feeff53a7931e68fc6 Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/freedesktop.scm6
-rw-r--r--gnu/packages/patches/xdg-desktop-portal-disable-configuration-search-exit.patch27
3 files changed, 32 insertions, 2 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 3fb1b39d6b..a4ba6dd65a 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -2415,6 +2415,7 @@ dist_patch_DATA = \
%D%/packages/patches/wpa-supplicant-dbus-group-policy.patch \
%D%/packages/patches/x265-arm-flags.patch \
%D%/packages/patches/xdg-desktop-portal-disable-portal-tests.patch\
+ %D%/packages/patches/xdg-desktop-portal-disable-configuration-search-exit.patch\
%D%/packages/patches/xdg-desktop-portal-wlr-harcoded-length.patch\
%D%/packages/patches/xf86-video-siliconmotion-fix-ftbfs.patch \
%D%/packages/patches/xfig-Enable-error-message-for-missing-libraries.patch \
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 7541490a31..34dfe20229 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -3213,8 +3213,10 @@ compatible with the well-known scripts of the same name.")
(sha256
(base32
"0r8y8qmzcfj7b7brqcxr9lg8pavfds815ffvj0kqc378fhgaln5q"))
- ;; Disable portal tests since they try to use fuse.
- (patches (search-patches "xdg-desktop-portal-disable-portal-tests.patch"))))
+ (patches (search-patches
+ ;; Disable portal tests since they try to use fuse.
+ "xdg-desktop-portal-disable-portal-tests.patch"
+ "xdg-desktop-portal-disable-configuration-search-exit.patch"))))
(build-system meson-build-system)
(arguments
`(#:configure-flags
diff --git a/gnu/packages/patches/xdg-desktop-portal-disable-configuration-search-exit.patch b/gnu/packages/patches/xdg-desktop-portal-disable-configuration-search-exit.patch
new file mode 100644
index 0000000000..eba07f8c35
--- /dev/null
+++ b/gnu/packages/patches/xdg-desktop-portal-disable-configuration-search-exit.patch
@@ -0,0 +1,27 @@
+From 37003d1f99246c88cbe7cf2f83616642e0fdf3fb Mon Sep 17 00:00:00 2001
+From: Rodion Goritskov <rodion.goritskov@gmail.com>
+Date: Fri, 27 Sep 2024 00:44:07 +0400
+Subject: [PATCH] portal-impl: Check if there are any configuration files in XDG_DESKTOP_PORTAL_DIR before exiting configuration search
+
+---
+ src/portal-impl.c | 5 ++---
+ 1 file changed, 2 insertions(+), 3 deletions(-)
+
+diff --git a/src/portal-impl.c b/src/portal-impl.c
+index 8c1fd53..8708409 100644
+--- a/src/portal-impl.c
++++ b/src/portal-impl.c
+@@ -438,9 +438,8 @@ load_portal_configuration (gboolean opt_verbose)
+
+ if (portal_dir != NULL)
+ {
+- load_config_directory (portal_dir, desktops, opt_verbose);
+- /* All other config directories are ignored when this is set */
+- return;
++ if (load_config_directory (portal_dir, desktops, opt_verbose))
++ return;
+ }
+
+ /* $XDG_CONFIG_HOME/xdg-desktop-portal/(DESKTOP-)portals.conf */
+--
+2.46.0