aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-08-18 21:04:34 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-25 20:46:46 +0100
commit62d7440b26d0af727e98fe3b11bdcce120ff5a19 (patch)
treefa57c1bcaf25e18294a20a6e1f21314fbd637b34
parentf705f4b42fec56cf3a91e3bf0f1a570b618cdcd1 (diff)
downloadguix-62d7440b26d0af727e98fe3b11bdcce120ff5a19.tar.gz
guix-62d7440b26d0af727e98fe3b11bdcce120ff5a19.zip
gnu: Add go-github-com-oklog-ulid-v2.
* gnu/packages/golang-xyz.scm (go-github-com-oklog-ulid-v2, go-ulid): New variables. Change-Id: I6512659023330ab1ff03bc9c2e43e3ad92a30490
-rw-r--r--gnu/packages/golang-xyz.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 11ec67339e..a369127c4f 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -5118,6 +5118,24 @@ millisecond)
@end itemize")
(license license:asl2.0)))
+(define-public go-github-com-oklog-ulid-v2
+ (package
+ (inherit go-github-com-oklog-ulid)
+ (name "go-github-com-oklog-ulid-v2")
+ (version "2.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/oklog/ulid")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1pxjrg48zrmzzdjpsz7b2d56x1vwix2wywgbbv3sdi5mqf0hz17y"))))
+ (arguments
+ (list
+ #:import-path "github.com/oklog/ulid/v2"))))
+
(define-public go-github-com-op-go-logging
(package
(name "go-github-com-op-go-logging")
@@ -6863,6 +6881,22 @@ tool."))))
" This package provides an command line interface (CLI)
tool."))))
+(define-public go-ulid
+ (package
+ (inherit go-github-com-oklog-ulid-v2)
+ (name "go-ulid")
+ (arguments
+ (list
+ #:install-source? #f
+ #:import-path "github.com/oklog/ulid/v2/cmd/ulid"
+ #:unpack-path "github.com/oklog/ulid/v2"))
+ (native-inputs
+ (list go-github-com-pborman-getopt))
+ (description
+ (string-append (package-description go-github-com-oklog-ulid)
+ " This package provides an command line interface (CLI)
+tool."))))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar