aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRutherther <rutherther@protonmail.com>2024-09-08 18:26:15 +0000
committerJohn Kehayias <john.kehayias@protonmail.com>2024-11-05 11:56:35 -0500
commit62a9c2d29ba5c682e34ae480fbd3c21ffdf26fb1 (patch)
tree501d3f2397d745f65a9e0959d9d3e864cfc8f91b
parent88a6cb6fc85376d19ed3632ba384349b34318069 (diff)
downloadguix-62a9c2d29ba5c682e34ae480fbd3c21ffdf26fb1.tar.gz
guix-62a9c2d29ba5c682e34ae480fbd3c21ffdf26fb1.zip
gnu: wlroots: Remove unneeded hwdata patch.
* gnu/packages/wm.scm (wlroots)[source]: Remove patch. * gnu/packages/patches/wlroots-hwdata-fallback.patch: Delete file. * gnu/local.mk (dist_patch_DATA): De-register it. Change-Id: I4be3e203b99f1d8e4d837164d55a8c06c8fc71ee Signed-off-by: John Kehayias <john.kehayias@protonmail.com>
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/wlroots-hwdata-fallback.patch46
-rw-r--r--gnu/packages/wm.scm4
3 files changed, 1 insertions, 50 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 06e8f1363c..8a85f56c8e 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -2318,7 +2318,6 @@ dist_patch_DATA = \
%D%/packages/patches/webrtc-audio-processing-x86-no-sse.patch \
%D%/packages/patches/webrtc-for-telegram-desktop-unbundle-libsrtp.patch \
%D%/packages/patches/websocketpp-fix-for-cmake-3.15.patch \
- %D%/packages/patches/wlroots-hwdata-fallback.patch \
%D%/packages/patches/wmctrl-64-fix.patch \
%D%/packages/patches/wmfire-dont-inline-draw-fire.patch \
%D%/packages/patches/wmfire-update-for-new-gdk-versions.patch \
diff --git a/gnu/packages/patches/wlroots-hwdata-fallback.patch b/gnu/packages/patches/wlroots-hwdata-fallback.patch
deleted file mode 100644
index 6468c7cbf3..0000000000
--- a/gnu/packages/patches/wlroots-hwdata-fallback.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-backend/drm: add hardcoded hwdata path fallback
-
-Add hardcoded fallback "/usr/share/hwdata/pnp.ids" as a
-temporary solution to get things working in Guix until
-hwdata ships with pkg-config file.
-
-diff --git a/backend/drm/meson.build b/backend/drm/meson.build
-index 6fcb2c15..ed95360a 100644
---- a/backend/drm/meson.build
-+++ b/backend/drm/meson.build
-@@ -1,8 +1,7 @@
- hwdata = dependency(
- 'hwdata',
-- required: 'drm' in backends,
-+ required: false,
- native: true,
-- not_found_message: 'Required for the DRM backend.',
- )
-
- libdisplay_info = dependency(
-@@ -19,15 +18,21 @@ libliftoff = dependency(
- required: false,
- )
-
--if not (hwdata.found() and libdisplay_info.found() and features['session'])
-+if hwdata.found()
-+ hwdata_dir = hwdata.get_variable(pkgconfig: 'pkgdatadir')
-+ pnp_ids = files(hwdata_dir / 'pnp.ids')
-+else
-+ pnp_ids = files('/usr/share/hwdata/pnp.ids')
-+endif
-+
-+if not (libdisplay_info.found() and features['session'])
- subdir_done()
- endif
-
--hwdata_dir = hwdata.get_variable(pkgconfig: 'pkgdatadir')
- pnpids_c = custom_target(
- 'pnpids.c',
- output: 'pnpids.c',
-- input: files(hwdata_dir / 'pnp.ids'),
-+ input: pnp_ids,
- feed: true,
- capture: true,
- command: files('gen_pnpids.sh'),
-
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 7a93827edc..8ff76043e6 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1735,9 +1735,7 @@ functionality to display information about the most commonly used services.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0niigjpy8xxrnw3v9b3bsksw2q3yy3qsa2xx0aazwpycw5zrff83"))
- ;; This patch can be removed once hwdata in Guix supports pkg-config
- (patches (search-patches "wlroots-hwdata-fallback.patch"))))
+ (base32 "0niigjpy8xxrnw3v9b3bsksw2q3yy3qsa2xx0aazwpycw5zrff83"))))
(build-system meson-build-system)
(arguments
`(#:phases