aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-08-26 20:23:00 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-08-26 20:31:17 +0200
commit61eea88ddea52b5f6959af5be3b28926a5e0200e (patch)
tree3d47c164e3bba613859e254ac5cac9d888e5d7b8
parentcc4cb24ed5d9f5104084169d284fbec53bcebebf (diff)
downloadguix-61eea88ddea52b5f6959af5be3b28926a5e0200e.tar.gz
guix-61eea88ddea52b5f6959af5be3b28926a5e0200e.zip
gnu: Add r-geometries.
* gnu/packages/cran.scm (r-geometries): New variable. Change-Id: I290a5cc2bda00859d27c7a91341acb20708c9abc
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b7c71706d1..ea918d2367 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -9564,6 +9564,29 @@ interface to @code{PostgreSQL}, a relational database.")
Optimization problems by using the simplex algorithm.")
(license license:gpl2+)))
+(define-public r-geometries
+ (package
+ (name "r-geometries")
+ (version "0.2.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "geometries" version))
+ (sha256
+ (base32 "040ljxmzbjdr76p81ygnn5y0gzckz5k2arxkih5m5f3b6g62laf6"))))
+ (properties `((upstream-name . "geometries")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-rcpp))
+ (native-inputs (list r-knitr))
+ (home-page "https://dcooley.github.io/geometries/")
+ (synopsis "Convert between R objects and geometric structures")
+ (description
+ "Geometry shapes in R are typically represented by matrices (points,
+lines), with more complex shapes being lists of matrices (polygons).
+Geometries will convert various R objects into these shapes. Conversion
+functions are available at both the R level, and through Rcpp.")
+ (license license:expat)))
+
(define-public r-geometry
(package
(name "r-geometry")