aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-04 11:37:35 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:57:16 +0200
commit6133a3e3587829b482d6fb4fc786a4dcb7c96263 (patch)
tree2639b5b7ea3668f1413d50c2e3fcce54e5423f64
parent86415b84e19226d91c3f0d812e33d9b5618fbe9c (diff)
downloadguix-6133a3e3587829b482d6fb4fc786a4dcb7c96263.tar.gz
guix-6133a3e3587829b482d6fb4fc786a4dcb7c96263.zip
gnu: Add rust-copypasta-0.10.
* gnu/packages/crates-io.scm (rust-copypasta-0.10): New variable. (rust-copypasta-0.8): Inherit from rust-copypasta-0.10. Change-Id: Ifacb857fadfdb9eeb0b917e49b143753d236960f
-rw-r--r--gnu/packages/crates-io.scm36
1 files changed, 28 insertions, 8 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index af77d3c9c3..89eacce077 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -14598,8 +14598,35 @@ similar to the nom parser combinators library.")
the standard library.")
(license (list license:expat license:asl2.0))))
+(define-public rust-copypasta-0.10
+ (package
+ (name "rust-copypasta")
+ (version "0.10.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "copypasta" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1bk5dby9jyn20d628l0cqjij738q1nqdqp8378f9x7mz951kcdbd"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-clipboard-win" ,rust-clipboard-win-3)
+ ("rust-objc" ,rust-objc-0.2)
+ ("rust-objc-foundation" ,rust-objc-foundation-0.1)
+ ("rust-objc-id" ,rust-objc-id-0.1)
+ ("rust-smithay-clipboard" ,rust-smithay-clipboard-0.7)
+ ("rust-x11-clipboard" ,rust-x11-clipboard-0.8))))
+ (home-page "https://github.com/alacritty/copypasta")
+ (synopsis "Get and set the contents of the OS-level clipboard")
+ (description
+ "Copypasta is a cross-platform library for getting and setting the
+contents of the OS-level clipboard.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-copypasta-0.8
(package
+ (inherit rust-copypasta-0.10)
(name "rust-copypasta")
(version "0.8.2")
(source (origin
@@ -14609,7 +14636,6 @@ the standard library.")
(sha256
(base32
"0wmidz38581b1xzpzf466pdaw3xam7nlsn0klndfr973brkwhgqk"))))
- (build-system cargo-build-system)
(arguments
`(#:cargo-inputs
(("rust-clipboard-win" ,rust-clipboard-win-3)
@@ -14617,13 +14643,7 @@ the standard library.")
("rust-objc-foundation" ,rust-objc-foundation-0.1)
("rust-objc-id" ,rust-objc-id-0.1)
("rust-smithay-clipboard" ,rust-smithay-clipboard-0.6)
- ("rust-x11-clipboard" ,rust-x11-clipboard-0.7))))
- (home-page "https://github.com/alacritty/copypasta")
- (synopsis "Get and set the contents of the OS-level clipboard")
- (description
- "Copypasta is a cross-platform library for getting and setting the
-contents of the OS-level clipboard.")
- (license (list license:expat license:asl2.0))))
+ ("rust-x11-clipboard" ,rust-x11-clipboard-0.7))))))
(define-public rust-copypasta-0.7
(package