aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:06 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:26 +0200
commit610748769a286b2c9450640d98020b74fd775798 (patch)
treed35d36f71617cb748a3c1bf002dd14ae93ce830f
parente5fdf051c9ef3d54ca7f81249a8efd3c4ea1c578 (diff)
downloadguix-610748769a286b2c9450640d98020b74fd775798.tar.gz
guix-610748769a286b2c9450640d98020b74fd775798.zip
gnu: Add trytond-account-payment-braintree.
* gnu/packages/tryton.scm (trytond-account-payment-braintree): New variable.
-rw-r--r--gnu/packages/tryton.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index db7f46f019..191ca0b9e3 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -806,6 +806,34 @@ average price of the posted invoice lines that are linked to it.")
payments for receivable or payable Account Move Lines.")
(license license:gpl3+)))
+(define-public trytond-account-payment-braintree
+ (package
+ (name "trytond-account-payment-braintree")
+ (version "6.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_account_payment_braintree" version))
+ (sha256
+ (base32 "0dgw47q4m5l13bhfl1kdpajh0q94pazdrq9sqzf1vg9mggai2gvi"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "account_payment_braintree"))
+ (native-inputs `(,@%standard-trytond-native-inputs))
+ (propagated-inputs
+ `(("python-braintree" ,python-braintree)
+ ("trytond" ,trytond)
+ ("trytond-account" ,trytond-account)
+ ("trytond-account-payment" ,trytond-account-payment)
+ ("trytond-party" ,trytond-party)))
+ (home-page
+ "https://docs.tryton.org/projects/modules-account-payment-braintree")
+ (synopsis "Tryton module for Braintree payment")
+ (description "The @emph{Account Payment Braintree} Tryton module allows
+receipt of payments using Braintree. It uses the Drop-in UI in a checkout
+form to handle the payment method nonce for card and other supported payment
+methods.")
+ (license license:gpl3+)))
+
(define-public trytond-account-product
(package
(name "trytond-account-product")