aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-03-28 11:17:24 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-07-19 00:45:06 +0300
commit5fa6941fac2ded752f2c39325664431b69e598be (patch)
tree31f7136de62743a96ded7f89553b6c6af86036d2
parente786cc4409cfe8dc148b74bcf0c8ec7a1af5c7ff (diff)
downloadguix-5fa6941fac2ded752f2c39325664431b69e598be.tar.gz
guix-5fa6941fac2ded752f2c39325664431b69e598be.zip
gnu: Add rust-watchexec-events-1.
* gnu/packages/crates-io.scm (rust-watchexec-events-1): New variable. Change-Id: I7699c8da5f66b1b539c6c9296b66b1746363faec
-rw-r--r--gnu/packages/crates-io.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 5b15a572a0..89c6a767f3 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -85859,6 +85859,31 @@ modifications.")
("rust-walkdir" ,rust-walkdir-2)
("rust-winapi" ,rust-winapi-0.3))))))
+(define-public rust-watchexec-events-1
+ (package
+ (name "rust-watchexec-events")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "watchexec-events" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1qra2hpkdf5ln1vb5jpxp17s3va7dm2svb8d067r2xgx0az3nq01"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:tests? #f ; `Event: serde::de::Deserialize<'_>` is not satisfied
+ #:cargo-inputs (("rust-nix" ,rust-nix-0.26)
+ ("rust-notify" ,rust-notify-5)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-watchexec-signals" ,rust-watchexec-signals-1))
+ #:cargo-development-inputs (("rust-serde-json" ,rust-serde-json-1)
+ ("rust-snapbox" ,rust-snapbox-0.4))))
+ (home-page "https://github.com/watchexec/watchexec")
+ (synopsis "Watchexec's event types")
+ (description "This package provides watchexec's event types.")
+ (license (list license:asl2.0 license:expat))))
+
(define-public rust-watchexec-signals-1
(package
(name "rust-watchexec-signals")