aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTroy Figiel <troy@troyfigiel.com>2023-12-27 23:13:02 +0100
committerMathieu Othacehe <othacehe@gnu.org>2023-12-28 10:23:41 +0100
commit5f2a3c3ebc4b230b2ec2a1719ed0b3d166992104 (patch)
tree0c273e12037021e634c7c1dc8dc3731288a6ab48
parent53f51a908bf80739d60a99c74ffbfc1242db6c11 (diff)
downloadguix-5f2a3c3ebc4b230b2ec2a1719ed0b3d166992104.tar.gz
guix-5f2a3c3ebc4b230b2ec2a1719ed0b3d166992104.zip
gnu: python-flake8-isort: Update to 6.1.0.
* gnu/packages/python-xyz.scm (python-flake8-isort): Update to 6.1.0. [arguments]<#:phases>: Update check phase, because tests have been moved to run_tests.py. [propagated-inputs]: Remove python-testfixtures. Change-Id: Iecaf50021c8f29fb083f7a85b7ac731836e97384 Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4d3041db2c..85a97eb633 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13081,13 +13081,13 @@ TODO notes checker plugin for flake8.")
(define-public python-flake8-isort
(package
(name "python-flake8-isort")
- (version "4.1.1")
+ (version "6.1.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "flake8-isort" version))
(sha256
- (base32 "05r7z0j9rqgy0a9261bhisairrz6w8hy5hy5kf2mhvhfnx53056q"))))
+ (base32 "0gk4q504v42hdzpkndczc0kkwnr85jn1h5pvb561jh65p91r6qyl"))))
(build-system python-build-system)
(arguments
(list
@@ -13096,8 +13096,8 @@ TODO notes checker plugin for flake8.")
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
- (invoke "pytest" "-vv")))))))
- (propagated-inputs (list python-flake8 python-isort python-testfixtures))
+ (invoke "pytest" "-vv" "run_tests.py")))))))
+ (propagated-inputs (list python-flake8 python-isort))
(native-inputs (list python-pytest))
(home-page "https://github.com/gforcada/flake8-isort")
(synopsis "Flake8 plugin integrating isort")