aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 23:50:38 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-19 20:33:30 +0200
commit5f2948f4293af52a2d90c22852fafdfe00bf744c (patch)
treecb7af554dcde4451d57bdb0d1a95638e778eae19
parente5b78ac25ebf87766edee47327ffacc65245ea30 (diff)
downloadguix-5f2948f4293af52a2d90c22852fafdfe00bf744c.tar.gz
guix-5f2948f4293af52a2d90c22852fafdfe00bf744c.zip
gnu: Add texlive-biblatex-true-citepages-omit.
* gnu/packages/tex.scm (texlive-biblatex-true-citepages-omit): New variable.
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 879cb0f65f..ac94061146 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4597,6 +4597,28 @@ work properly with newer versions of BibLaTeX.")
(@code{plain}, @code{abbrev}, @code{unsrt} and @code{alpha}) with BibLaTeX.")
(license license:lppl1.3c)))
+(define-public texlive-biblatex-true-citepages-omit
+ (package
+ (name "texlive-biblatex-true-citepages-omit")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/biblatex-true-citepages-omit/"
+ "tex/latex/biblatex-true-citepages-omit/")
+ (base32
+ "1mfkmn5g6r61mlyf3vx98q18a042yjkmh3drid9vs0kaj66di4n5")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/biblatex-true-citepages-omit")
+ (synopsis
+ "Correct some limitations of BibLaTeX @samp{citepages=omit} option")
+ (description
+ "This package deals with a limitation of the @samp{citepages=omit} option
+of the verbose family of BibLaTeX citestyles. The option works when you
+@code{\\cite[xx]@{key@}}, but not when you @code{\\cite[\\pno~xx, some
+text]@{key@}}. The package corrects this problem.")
+ (license license:lppl1.3+)))
+
(define-public texlive-bibleref
(package
(name "texlive-bibleref")