aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-10-23 04:57:09 -0400
committerLeo Famulari <leo@famulari.name>2016-10-23 05:01:02 -0400
commit5ed7f28da5dd829eccccba4835315a9861bed451 (patch)
treebd6d6a382bfeba1915b97c4ab0b8cf30b1f52986
parentd78b652c168626866a69b281619fbe17a2f2b025 (diff)
downloadguix-5ed7f28da5dd829eccccba4835315a9861bed451.tar.gz
guix-5ed7f28da5dd829eccccba4835315a9861bed451.zip
gnu: mpg321: Update to 0.3.2.
* gnu/packages/mp3.scm (mpg321): Update to 0.3.2.
-rw-r--r--gnu/packages/mp3.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/mp3.scm b/gnu/packages/mp3.scm
index 80028beb21..37cc870e2c 100644
--- a/gnu/packages/mp3.scm
+++ b/gnu/packages/mp3.scm
@@ -313,14 +313,14 @@ command-line tool as well as a C library, libmpg123.")
(define-public mpg321
(package
(name "mpg321")
- (version "0.3.1")
+ (version "0.3.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/mpg321/mpg321/"
version "/mpg321-" version ".tar.gz"))
(sha256
(base32
- "0yamsqvj15nsxxnjs9mgyslzx7krgsfk3q1hk3g6l8w9bbbj770b"))))
+ "0ki8mh76bbmdh77qsiw682dvi8y468yhbdabqwg05igmwc1wqvq5"))))
(build-system gnu-build-system)
(arguments '(#:configure-flags '("--disable-alsa")))
(inputs
iv>
+ (spaces (read-while (cut char-set-contains? char-set:blank <>) port))
+ (c (peek-char port)))
+ (unread-string spaces port)
(and (every (cut string-ci<> s <>) cabal-reserved-words)
- (not (char=? (last (string->list s)) #\:)))))
+ (and (not (char=? (last (string->list s)) #\:))
+ (not (char=? #\: c))))))
(define (is-test s port)
(let ((tests-rx (make-regexp "os|arch|flag|impl"))
+ (spaces (read-while (cut char-set-contains? char-set:blank <>) port))
(c (peek-char port)))
- (and (regexp-exec tests-rx s) (char=? #\( c))))
+ (if (and (regexp-exec tests-rx s) (char=? #\( c))
+ #t
+ (begin (unread-string spaces port) #f))))
;; Lexers for individual tokens.
@@ -509,7 +516,7 @@ LOC is the current port location."
((is-false w) (lex-false loc))
((is-and w) (lex-and loc))
((is-or w) (lex-or loc))
- ((is-id w) (lex-id w loc))
+ ((is-id w port) (lex-id w loc))
(else (unread-string w port) #f))))
(define (lex-line port loc)