aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-07 20:44:25 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:19:06 +0000
commit5eb3bb76405880a44c453eab3e1ea8ddf2452ccc (patch)
treeb1d7e0cf7d27d6973fb1df75f9c00b0ecac580f8
parent1228b3134f102438b65f49ac0edcb128df8129a7 (diff)
downloadguix-5eb3bb76405880a44c453eab3e1ea8ddf2452ccc.tar.gz
guix-5eb3bb76405880a44c453eab3e1ea8ddf2452ccc.zip
gnu: python-cplot: Adjust inputs.
* gnu/packages/python-xyz.scm (python-cplot) [native-inputs]: Add python-setuptools and python-wheel. Change-Id: Ie73c88278249a1efb8c710f1d9b5438a76b88df7
-rw-r--r--gnu/packages/python-xyz.scm14
1 files changed, 9 insertions, 5 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 64439e4895..0ce7244dbc 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9924,11 +9924,15 @@ clean plots with a minimalistic style.")
(sha256
(base32 "0zk7hpq358sbympmkms7w2wjs7nw8mdfvkvdasblg2nhqayv42qz"))))
(build-system pyproject-build-system)
- (propagated-inputs (list python-matplotlib
- python-matplotx
- python-npx
- python-numpy))
- (native-inputs (list python-pytest))
+ (native-inputs
+ (list python-pytest
+ python-setuptools
+ python-wheel))
+ (propagated-inputs
+ (list python-matplotlib
+ python-matplotx
+ python-npx
+ python-numpy))
(home-page "https://github.com/nschloe/cplot")
(synopsis "Plot complex-valued functions")
(description "@code{cplot} is a Python library for plotting