aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-06 22:03:43 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:19:04 +0000
commit5e4951a53901ccf4500b7392564c9ff72b6bc624 (patch)
treec3d49391a4e3b5223f739c31e3d60e7f77a2df59
parent9023969fc66715287fef8dbcd16890944efe80c2 (diff)
downloadguix-5e4951a53901ccf4500b7392564c9ff72b6bc624.tar.gz
guix-5e4951a53901ccf4500b7392564c9ff72b6bc624.zip
gnu: python-defusedxml: Update to 0.7.1.
* gnu/packages/xml.scm (python-defusedxml): Update to 0.7.1. [native-inputs]: Add python-setuptools and python-wheel. Change-Id: Id6fd8fbc302f4c6a47d1b269efa9318a6e52919f
-rw-r--r--gnu/packages/xml.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 0ac9c85e77..5bbd1dd64e 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -1479,16 +1479,18 @@ files. It is designed to be fast and to handle large input files.")
(define-public python-defusedxml
(package
(name "python-defusedxml")
- (version "0.6.0")
+ (version "0.7.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "defusedxml" version))
(sha256
- (base32
- "1xbp8fivl3wlbyg2jrvs4lalaqv1xp9a9f29p75wdx2s2d6h717n"))))
- (build-system python-build-system)
- (home-page "https://bitbucket.org/tiran/defusedxml")
+ (base32 "0s9ym98jrd819v4arv9gmcr6mgljhxd9q866sxi5p4c5n4nh7cqv"))))
+ (build-system pyproject-build-system)
+ (home-page "https://github.com/tiran/defusedxml")
+ (native-inputs
+ (list python-setuptools
+ python-wheel))
(synopsis "XML bomb protection for Python stdlib modules")
(description
"Defusedxml provides XML bomb protection for Python stdlib modules.")