aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-03 09:29:34 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-09-03 15:43:09 +0100
commit5e2d4317d16682db67fa5cdeabe24da572474778 (patch)
treed4d78092b30b382ade124a8768654554e9464654
parentd54385946ab94ae500cd30ec38df599dd4a66d76 (diff)
downloadguix-5e2d4317d16682db67fa5cdeabe24da572474778.tar.gz
guix-5e2d4317d16682db67fa5cdeabe24da572474778.zip
gnu: go-github-com-zalando-go-keyring: Update to 0.2.5.
* gnu/packages/golang.scm (go-github-com-zalando-go-keyring): Update to 0.2.5. [propagated-inputs]: Remove go-github-com-godbus-dbus; add go-github-com-godbus-dbus-v5. Change-Id: I21fafc683ae802e0ca7b6bdb9e1bb100f25879f9
-rw-r--r--gnu/packages/golang.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index a954e24365..773529425e 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6759,7 +6759,7 @@ formatting information, rather than the current locale name.")
(define-public go-github-com-zalando-go-keyring
(package
(name "go-github-com-zalando-go-keyring")
- (version "0.1.0")
+ (version "0.2.5")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -6768,13 +6768,13 @@ formatting information, rather than the current locale name.")
(file-name (git-file-name name version))
(sha256
(base32
- "0kj54nkiyccy6m9iy9a53f6412a54xk96j88jaiq35yzdgfa4z3p"))))
+ "1p6qlsbj9rmqiwz9ly4c7jmifcx8m45xjhsbdwdvw2jzw5jc2ch1"))))
(build-system go-build-system)
(arguments
`(#:tests? #f ;XXX: Fix dbus tests
#:import-path "github.com/zalando/go-keyring"))
(propagated-inputs
- (list go-github-com-godbus-dbus dbus))
+ (list go-github-com-godbus-dbus-v5 dbus))
(home-page "https://github.com/zalando/go-keyring/")
(synopsis "Library for working with system keyring")
(description "@code{go-keyring} is a library for setting, getting and