aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:01:26 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:06:16 +0200
commit5baeb3f0d9ea2fd46244e0c3b62c4c97cce6f7a4 (patch)
treef3f6cce43bb85277e0bedb49b4c6e0a7ba5c58b8
parentc9bc7a0314f937f78dfb03150aa5b9a34daceb55 (diff)
downloadguix-5baeb3f0d9ea2fd46244e0c3b62c4c97cce6f7a4.tar.gz
guix-5baeb3f0d9ea2fd46244e0c3b62c4c97cce6f7a4.zip
gnu: Add texlive-smart-eqn.
* gnu/packages/tex.scm (texlive-smart-eqn): New variable.
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 616315fb64..0ddb31796c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -95975,6 +95975,31 @@ a chapter named List that contains separate sections for each list of figures,
tables, etc.")
(license license:lppl)))
+(define-public texlive-smart-eqn
+ (package
+ (name "texlive-smart-eqn")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/smart-eqn/"
+ "source/latex/smart-eqn/"
+ "tex/latex/smart-eqn/")
+ (base32
+ "1w98b1m1i43rk12392vqbw92133ijf5af0xwd85a0bjixjfrjdwb")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/smart-eqn")
+ (synopsis "Automatic math symbol styling for LaTeX documents")
+ (description
+ "In LaTeX typesetting, one usually needs to use different variants of a math
+symbol to clarify the meanings. For example, in linear algebra literature, it
+is common to use boldfaced symbols to represent vectors, and normal symbols to
+represent scalars. However, applying these variants by typing
+@code{\\mathbf}, @code{\\mathrm} commands manually can be daunting. This
+package aims to provide an automatic and customizable approach for math symbol
+styling which eliminates the need to enter style commands repeatedly.")
+ (license license:lppl1.3c)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar