aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-01 21:48:26 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-14 15:11:55 -0400
commit5b42a71571ef59b1e339fd2a66fc7ee32b44bc60 (patch)
treefeda2113ed454882b51140cd2e74eb18ea341ecb
parent9703715db8707ffddd4c2637626c4765ed8f7189 (diff)
downloadguix-5b42a71571ef59b1e339fd2a66fc7ee32b44bc60.tar.gz
guix-5b42a71571ef59b1e339fd2a66fc7ee32b44bc60.zip
gnu: python-trio: Update to 0.22.0.
* gnu/packages/python-xyz.scm (python-trio): Update to 0.22.0. [arguments]: Break long line in check phase. [propagated-inputs]: Add python-cffi and python-exceptiongroup.
-rw-r--r--gnu/packages/python-xyz.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ca82e0c73e..05920bdf72 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -24826,13 +24826,13 @@ project.")
(define-public python-trio
(package
(name "python-trio")
- (version "0.20.0")
+ (version "0.22.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "trio" version))
(sha256
- (base32 "0w30cwmdwfa8zq2agqv3h62jzwwsk7ms8f683ag8f3jx279m42k7"))))
+ (base32 "1kxa9v0cds0xnklvzppv4ix4xg81r73p5pm4qlvv2iqa832z2s6f"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -24858,7 +24858,8 @@ project.")
;; Assertion errors.
" and not test_guest_mode_ki"
" and not test_run_in_trio_thread_ki"
- " and not test_simple_cancel_scope_usage_doesnt_create_cyclic_garbage"
+ " and not test_simple_cancel_scope_usage_doesnt_create\
+_cyclic_garbage"
" and not test_nursery_cancel_doesnt_create_cyclic_garbage"
" and not test_cancel_scope_exit_doesnt_create_cyclic_garbage"
" and not test_locals_destroyed_promptly_on_cancel"
@@ -24888,6 +24889,8 @@ project.")
(propagated-inputs
(list python-async-generator
python-attrs
+ python-cffi
+ python-exceptiongroup
python-idna
python-outcome
python-sniffio