aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-01 21:10:41 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-28 22:22:10 -0400
commit59c10293005e3487335ce0dc1a624171c243c5a6 (patch)
tree5378dd41059e19ff2313dc35a4f33bbd83b7ca6f
parent4e5cdaefa72058e1af25b2d50deb41d55d02bba5 (diff)
downloadguix-59c10293005e3487335ce0dc1a624171c243c5a6.tar.gz
guix-59c10293005e3487335ce0dc1a624171c243c5a6.zip
gnu: ruby-simplecov: Update to 0.22.0.
* gnu/packages/ruby.scm (ruby-simplecov): Update to 0.22.0. [native-inputs]: Delete field. [propagated-inputs]: Add ruby-simplecov-json-formatter. (ruby-rubycop-ast) [phases]: Add a relax-dependencies phase. [home-page]: Update URL.
-rw-r--r--gnu/packages/ruby.scm18
1 files changed, 12 insertions, 6 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index bc67fa5bd9..bad0301ea3 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3406,26 +3406,27 @@ Ruby code coverage tool.")
(define-public ruby-simplecov
(package
(name "ruby-simplecov")
- (version "0.17.1")
+ (version "0.22.0")
(source (origin
(method url-fetch)
(uri (rubygems-uri "simplecov" version))
(sha256
(base32
- "1135k46nik05sdab30yxb8264lqiz01c8v000g16cl9pjc4mxrdw"))))
+ "198kcbrjxhhzca19yrdcd6jjj9sb51aaic3b0sc3pwjghg3j49py"))))
(build-system ruby-build-system)
;; Simplecov depends on rubocop for code style checking at build time.
;; Rubocop needs simplecov at build time.
(arguments `(#:tests? #f))
(propagated-inputs
- (list ruby-json ruby-docile ruby-simplecov-html))
- (native-inputs
- (list bundler))
+ (list ruby-json
+ ruby-docile
+ ruby-simplecov-html
+ ruby-simplecov-json-formatter))
(synopsis "Code coverage framework for Ruby")
(description "SimpleCov is a code coverage framework for Ruby with a
powerful configuration library and automatic merging of coverage across test
suites.")
- (home-page "https://github.com/colszowka/simplecov")
+ (home-page "https://github.com/simplecov-ruby/simplecov")
(license license:expat)))
(define-public ruby-useragent
@@ -7134,6 +7135,11 @@ inspired by the Sinatra microframework style of specifying actions:
(arguments
`(#:test-target "spec"
#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'relax-dependencies
+ (lambda _
+ (substitute* "Gemfile"
+ (("gem 'simplecov', '~> 0.10', '< 0.18'")
+ "gem 'simplecov', '~> 0.10'"))))
(add-before 'build 'generate-lexer
(lambda _
(setenv "RUBOCOP_VERSION" "none")