aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-01 21:12:30 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-09-03 15:43:10 +0100
commit593327e9f1656b7b3916da7e43ac0d2206da4280 (patch)
treec629a571ebac7ec23bfdfa80e50dd159c775df2b
parentc31d83e77dd3fdcac09c7a19ac572a9d18784072 (diff)
downloadguix-593327e9f1656b7b3916da7e43ac0d2206da4280.tar.gz
guix-593327e9f1656b7b3916da7e43ac0d2206da4280.zip
gnu: go-github-com-pion-transport-v2: Update to 2.2.10.
* gnu/packages/golang-web.scm (go-github-com-pion-transport-v2): Update to 2.2.10. [native-inputs]: Add go-github-com-stretchr-testify. [propagated-inputs]: Add go-github-com-wlynxg-anet. Change-Id: I34393cc27ff5bfb722ffd395c137ba55a35f4a93
-rw-r--r--gnu/packages/golang-web.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 167e9ef07a..1238cfc8c9 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -3828,7 +3828,7 @@ throughout the @url{https://github.com/pion, Pion} modules.")
(package
(inherit go-github-com-pion-transport)
(name "go-github-com-pion-transport-v2")
- (version "2.2.5")
+ (version "2.2.10")
(source
(origin
(inherit (package-source go-github-com-pion-transport))
@@ -3837,10 +3837,15 @@ throughout the @url{https://github.com/pion, Pion} modules.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "00q3v37l56yr1ch25g5w70jy8y923csbvy4krvy4dv3h5f1mdpmf"))))
+ (base32 "0g5pg6mz61blprccxzysbwldkil84qgwp6404lsp4m9wh44312hf"))))
(arguments
(list
- #:import-path "github.com/pion/transport/v2"))))
+ #:import-path "github.com/pion/transport/v2"))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (propagated-inputs
+ (modify-inputs (package-propagated-inputs go-github-com-pion-transport)
+ (prepend go-github-com-wlynxg-anet)))))
(define-public go-github-com-pion-transport-v3
(package