aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-02-11 00:55:50 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-02-11 01:03:26 +0100
commit58b85de9ee7124e79d15ca38902007f5306f625e (patch)
treeddd75430db8026042311c2c31fa34443a816dce7
parent22da0a1e288b21e296ea24c4591928c32f572d6e (diff)
downloadguix-58b85de9ee7124e79d15ca38902007f5306f625e.tar.gz
guix-58b85de9ee7124e79d15ca38902007f5306f625e.zip
gnu: r-qgraph: Update to 1.6.9.
* gnu/packages/cran.scm (r-qgraph): Update to 1.6.9. [propagated-inputs]: Remove r-bdgraph, r-d3network, r-ggraph, r-huge, and r-tidygraph.
-rw-r--r--gnu/packages/cran.scm11
1 files changed, 3 insertions, 8 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 736fd68727..3c4076adee 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22163,30 +22163,26 @@ network, tree, dendrogram, and Sankey graphs from R using data frames.")
(define-public r-qgraph
(package
(name "r-qgraph")
- (version "1.6.5")
+ (version "1.6.9")
(source
(origin
(method url-fetch)
(uri (cran-uri "qgraph" version))
(sha256
(base32
- "0pwys9irxvp0ap158drplyypkplbmwqinv0fmlsblk7q875cr592"))))
+ "153bqfmsrghkg7598nfr57r3cxv6dn6ir084njl2sqq5np0sj9di"))))
(properties `((upstream-name . "qgraph")))
(build-system r-build-system)
(propagated-inputs
`(("r-abind" ,r-abind)
- ("r-bdgraph" ,r-bdgraph)
("r-colorspace" ,r-colorspace)
("r-corpcor" ,r-corpcor)
- ("r-d3network" ,r-d3network)
("r-dplyr" ,r-dplyr)
("r-fdrtool" ,r-fdrtool)
("r-ggplot2" ,r-ggplot2)
- ("r-ggraph" ,r-ggraph)
("r-glasso" ,r-glasso)
("r-gtools" ,r-gtools)
("r-hmisc" ,r-hmisc)
- ("r-huge" ,r-huge)
("r-igraph" ,r-igraph)
("r-jpeg" ,r-jpeg)
("r-lavaan" ,r-lavaan)
@@ -22196,8 +22192,7 @@ network, tree, dendrogram, and Sankey graphs from R using data frames.")
("r-png" ,r-png)
("r-psych" ,r-psych)
("r-rcpp" ,r-rcpp)
- ("r-reshape2" ,r-reshape2)
- ("r-tidygraph" ,r-tidygraph)))
+ ("r-reshape2" ,r-reshape2)))
(home-page "http://sachaepskamp.com/qgraph/")
(synopsis "Weighted network visualization and analysis")
(description
.scm?id=52c529ff20b389eb64ac033586e6b1a5c5d82cb5'>git-authenticate: Disallow SHA1 (and MD5) signatures.Ludovic Courtès * guix/git-authenticate.scm (commit-signing-key): Add #:disallowed-hash-algorithms and honor it. (authenticate-commit)[recent-commit?]: New variable. Pass #:disallowed-hash-algorithms to 'commit-signing-key'. * tests/git-authenticate.scm ("signed commits, SHA1 signature"): New test. 2020-06-07git-authenticate: Prevent removal of '.guix-authorizations'.Ludovic Courtès * guix/git-authenticate.scm (commit-authorized-keys) [parents-have-authorizations-file?, assert-parents-lack-authorizations]: New procedures. Use the latter before returning DEFAULT-AUTHORIZATIONS. * guix/git.scm (false-if-git-not-found): Export. * guix/tests/git.scm (populate-git-repository): Add 'remove' clause. * tests/git-authenticate.scm ("signed commits, .guix-authorizations removed"): New test. 2020-06-05git-authenticate: Add tests.Ludovic Courtès * guix/tests/git.scm (call-with-environment-variables) (with-environment-variables): Remove. * guix/tests/git.scm (populate-git-repository): Add clauses for signed commits and signed merges. * guix/tests/gnupg.scm: New file. * tests/git-authenticate.scm: New file. * tests/ed25519bis.key, tests/ed25519bis.sec: New files. * Makefile.am (dist_noinst_DATA): Add 'guix/tests/gnupg.scm'. (SCM_TESTS): Add 'tests/git-authenticate.scm'. (EXTRA_DIST): Add tests/ed25519bis.{key,sec}.