aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNikola <nikola@radojevic.rs>2024-08-18 13:59:45 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2024-08-18 02:00:00 +0200
commit58a839273d1e4fac2b3a0ec456aabdf82deaa124 (patch)
tree76fd515cd05cd6ba8472936061e83c935bc55c90
parentb1b3724996952102ad2751fa5111c6e8680b2ed4 (diff)
downloadguix-58a839273d1e4fac2b3a0ec456aabdf82deaa124.tar.gz
guix-58a839273d1e4fac2b3a0ec456aabdf82deaa124.zip
gnu: at-spi2-core: Remove unnecessary test timeout.
Guix provides its own superior-quality time-outs. * gnu/packages/gtk.scm (at-spi2-core)[arguments]: Remove the ‘timeout’ argument from the test invocation. Change-Id: Ic324c5992d48cafa4b6b9856b381d461083d8de2 Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
-rw-r--r--gnu/packages/gtk.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 04183fa806..7d3bd9a195 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -856,6 +856,9 @@ ever use this library.")
(with-directory-excursion (string-append "../at-spi2-core-"
#$version "")
(invoke "dbus-run-session" "--" "ci/run-registryd-tests.sh")
+ (substitute* "tests/atspi/meson.build"
+ ;; Remove a timeout causing aarch64 build failures.
+ ((", timeout: [0-9]+") ""))
(substitute* "ci/run-tests.sh"
(("ps auxwww") "") ;avoid a dependency on procps
(("meson test -C _build")