aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 16:44:23 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:42:17 +0200
commit5888a93b013e113eecffd79ea400db40b3e6d844 (patch)
treeb03dbbb5d1d230648320da9f5d642cfe3f85d934
parentb4fd27a7e15b94d3d495dc79b99e621b2efeb8e8 (diff)
downloadguix-5888a93b013e113eecffd79ea400db40b3e6d844.tar.gz
guix-5888a93b013e113eecffd79ea400db40b3e6d844.zip
gnu: Add texlive-rest-api.
* gnu/packages/tex.scm (texlive-rest-api): New variable.
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 58b81fac80..3bec8103fe 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5817,6 +5817,28 @@ solution of a linear system;
@end itemize")
(license license:lppl1.3c)))
+(define-public texlive-rest-api
+ (package
+ (name "texlive-rest-api")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/rest-api/"
+ "source/latex/rest-api/"
+ "tex/latex/rest-api/")
+ (base32
+ "1yv81yisaqkxnq33803z7kx3rk6hsdnyza0dzgqmkf6x1jmsnlp9")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/rest-api")
+ (synopsis "Describing a REST API")
+ (description
+ "This LaTeX package provides macros to describe REST APIs for
+documentation purposes. The endpoints can hold the following information:
+method description path parameter request body and content type response body,
+content type and status code.")
+ (license license:lppl1.3c)))
+
(define-public texlive-bibtex8
(package
(name "texlive-bibtex8")