aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 15:09:22 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 15:45:53 +0200
commit584013f2abfe6c76233bb9c5ef816603c61aff36 (patch)
tree791a1b8d4dc1d4701430221ea8fe808f2f540b64
parentba563ec84a6b5aec30b9542870bf87fa45d4adac (diff)
downloadguix-584013f2abfe6c76233bb9c5ef816603c61aff36.tar.gz
guix-584013f2abfe6c76233bb9c5ef816603c61aff36.zip
gnu: Add texlive-go.
* gnu/packages/tex.scm (texlive-go): New variable.
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 345d3e14e7..9edcaa57cd 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6917,6 +6917,27 @@ a possibility of optical centering and right-hanging alignment of lines broken
because of length.")
(license license:lppl)))
+(define-public texlive-go
+ (package
+ (name "texlive-go")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/fonts/go/" "fonts/source/public/go/"
+ "fonts/tfm/public/go/" "source/fonts/go/"
+ "tex/latex/go/")
+ (base32
+ "1cvxfz9m7fx62iiz00f7qlywrmwwnpk0xzlyv63c90ji9xzfawcv")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (native-inputs (list texlive-metafont))
+ (home-page "https://ctan.org/pkg/go")
+ (synopsis "Fonts and macros for typesetting go games")
+ (description
+ "The macros provide for nothing more complicated than the standard
+19x19 board; the fonts are written in Metafont.")
+ (license license:public-domain)))
+
(define-public texlive-gost
(package
(name "texlive-gost")