aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-09-17 14:49:46 +0900
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-09-22 15:19:51 +0900
commit55db928dcbb73d6d03c1af30b070cd65c835109d (patch)
treeb2143f39ef91e3e5822dbf06660269c36866651c
parente84e762a0364cfd1d9a343301a11b4e9c0daa1bf (diff)
downloadguix-55db928dcbb73d6d03c1af30b070cd65c835109d.tar.gz
guix-55db928dcbb73d6d03c1af30b070cd65c835109d.zip
gnu: Add evtest-qt.
* gnu/packages/games.scm (evtest-qt): New variable. Change-Id: Ifccb54509b4469c923126b100094e06e93383208
-rw-r--r--gnu/packages/games.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 5720d17bb3..9f02f32864 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -9844,6 +9844,30 @@ certainly not least as a fun, realistic, and challenging desktop flight
simulator.")
(license license:gpl2+)))
+(define-public evtest-qt
+ (package
+ (name "evtest-qt")
+ (version "0.2.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Grumbel/evtest-qt")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1wfzkgq81764qzxgk0y5vvpxcrb3icvrr4dd4mj8njrqgbwmn0mw"))))
+ (build-system cmake-build-system)
+ (arguments (list #:tests? #f)) ;no test suite
+ (native-inputs (list tinycmmc))
+ (inputs (list qtbase-5))
+ (home-page "https://github.com/Grumbel/evtest-qt")
+ (synopsis "Evdev Joystick Tester")
+ (description "@command{evtest-qt} is a simple joystick tester for devices
+using the @code{evdev} generic input event interface. It provides a list of
+attached joysticks and displays which buttons and axis are pressed.")
+ (license license:gpl3+)))
+
(define-public jstest-gtk
;; There is no recent tagged release; use the latest commit.
(let ((commit "60fe6ebdbc6719945be3f04988667dea569085be")