aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMekeor Melire <mekeor.melire@gmail.com>2025-02-05 21:12:48 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2025-02-05 21:54:07 +0000
commit55a2baf1271d8bcd39b876642539ae5e3d9a5892 (patch)
tree136fc73eb04c8b3e77f737449fbc8ab4db7e6088
parenta8f223f91cf1170c85c0133e12856476e40a8288 (diff)
downloadguix-55a2baf1271d8bcd39b876642539ae5e3d9a5892.tar.gz
guix-55a2baf1271d8bcd39b876642539ae5e3d9a5892.zip
gnu: Add python-publicsuffixlist.
It was preoposed in #48514 on <2021-05-19>. * gnu/packages/python-web.scm (python-publicsuffixlist): New variable. Change-Id: Iacecd5e9e49f9136935a65c83c09a643e371738b Reviewed-by: Xinglu Chen <public@yoctocell.xyz> Co-authored-by: Sharlatan Hellseher <sharlatanus@gmail.com> Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/python-web.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index cc6509ea1d..6f6b1dadfe 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -47,6 +47,7 @@
;;; Copyright © 2021, 2022, 2024 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2021, 2022, 2024 jgart <jgart@dismail.de>
;;; Copyright © 2021 Alice Brenon <alice.brenon@ens-lyon.fr>
+;;; Copyright © 2021 Mekeor Melire <mekeor.melire@gmail.com>
;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
;;; Copyright © 2022, 2023, 2025 Felix Gruber <felgru@posteo.net>
@@ -1464,6 +1465,34 @@ Model} (SAM) templates into AWS CloudFormation templates.")
emit information from within their applications to the AWS X-Ray service.")
(license license:asl2.0)))
+(define-public python-publicsuffixlist
+ (package
+ (name "python-publicsuffixlist")
+ (version "1.0.2.20250202")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "publicsuffixlist" version))
+ (sha256
+ (base32 "0llam7g7sv08lcfgy18iph8br8ldjmy2qbjaykc9pd3z4iisb0yd"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-setuptools
+ python-wheel))
+ (home-page "https://github.com/ko-zu/psl")
+ (synopsis "Public suffix list for Python")
+ (description
+ "This package provides an implementation of
+@url{https://publicsuffix.org/, Public Suffix List } as Python library.
+
+Features:
+@itemize
+@item supports IDN (unicode and punycoded)
+@item shipped with built-in PSL and an updater script
+@item written in Pure Python with no library dependencies
+@end itemize")
+ (license license:mpl2.0)))
+
(define-public python-python3-saml
(package
(name "python-python3-saml")