aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2016-08-06 18:34:21 +0800
committer宋文武 <iyzsong@gmail.com>2016-08-23 19:46:19 +0800
commit554b2dac09bef4dd0df4da6b869ebb4eb2ad2b55 (patch)
treee2897724baedde3e98621d444330a84dd532d75e
parentd1fb4af6b8118b62213f722a0bbeec3dddcec5a3 (diff)
downloadguix-554b2dac09bef4dd0df4da6b869ebb4eb2ad2b55.tar.gz
guix-554b2dac09bef4dd0df4da6b869ebb4eb2ad2b55.zip
gnu: evince: Don't install 'icon-theme.cache'.
* gnu/packages/gnome.scm (evince)[arguments]: Add 'skip-gtk-update-icon-cache' phase.
-rw-r--r--gnu/packages/gnome.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index e133fcca5b..9462c702e4 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -480,7 +480,15 @@ forgotten when the session ends.")
;; FIXME: Tests fail with:
;; ImportError: No module named gi.repository
;; Where should that module come from?
- #:tests? #f))
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'skip-gtk-update-icon-cache
+ ;; Don't create 'icon-theme.cache'.
+ (lambda _
+ (substitute* "data/Makefile"
+ (("gtk-update-icon-cache") "true"))
+ #t)))))
(inputs
`(("libspectre" ,libspectre)
("djvulibre" ,djvulibre)